Vulnerability · CVE-2023-51441
** UNSUPPORTED WHEN ASSIGNED ** Improper Input Validation vulnerability in Apache Axis allowed users with access to the admin service to perform possible SSRF This issue affects Ap
Published Jan 6, 2024 · catalog updated Oct 25, 2026 · ** UNSUPPORTED WHEN ASSIGNED
Last checked Nov 6, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2023-51441. EPSS is 1.21%. Act only if a listed version of ** UNSUPPORTED WHEN ASSIGNED is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (** UNSUPPORTED WHEN ASSIGNED).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- High7.2
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 1.21%
- Remediation
- Advisory link
- Affected products
- Debian:12 axis · Debian:13 axis · Debian:14 axis
** UNSUPPORTED WHEN ASSIGNED ** Improper Input Validation vulnerability in Apache Axis allowed users with access to the admin service to perform possible SSRF This issue affects Apache Axis: through 1.3. As Axis 1 has been EOL we recommend you migrate to a different SOAP engine, such as Apache Axis 2/Java. Alternatively you could use a build of Axis with the patch from https://github.com/apache/axis-axis1-java/commit/685c309febc64aa393b2d64a05f90e7eb9f73e06 applied. The Apache Axis project does not expect to create an Axis 1.x release fixing this problem, though contributors that would like to work towards this are welcome.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- Debian:12 axis1.4-28, 1.4-28+deb12u1, 1.4-29
- Debian:13 axis1.4-29, 1.4-30
- Debian:14 axis0 → 1.4-30
How to fix CVE-2023-51441
Upgrade
CVE-2023-51441 lists a fix boundary at 1.4-30. Compare the installed build with that boundary before you change production.
Version check
Fixed in 1.4-30 · 5 other ranges on the advisory
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2023-51441. EPSS is 1.21%. Act only if a listed version of ** UNSUPPORTED WHEN ASSIGNED is installed.
Which versions are affected?
Compare what you have installed with 1.4-28, 1.4-28+deb12u1, 1.4-29, 1.4-29, 1.4-30, 0 → 1.4-30. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 1.21%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Jan 6, 2024 · Trivy Vulnerability DB
Detected
** UNSUPPORTED WHEN ASSIGNED ** Improper Input Validation vulnerability in Apache Axis allowed users with access to the admin service to perform possible SSRF This issue affects Apache Axis: through 1.3. As Axis 1 has been EOL we recommend you migrate to a different SOAP engine, such as Apache Axis 2/Java. Alternatively you could use a build of Axis with the patch from https://github.com/apache/ax
Oct 25, 2026 · Trivy Vulnerability DB
Fix available
axis fixed in 1.4-30
Oct 25, 2026 · Trivy Vulnerability DB
Fix available
axis fixed in 1.4-30
Oct 25, 2026 · Trivy Vulnerability DB
Updated
** UNSUPPORTED WHEN ASSIGNED ** Improper Input Validation vulnerability in Apache Axis allowed users with access to the admin service to perform possible SSRF This issue affects Apache Axis: through 1.3. As Axis 1 has been EOL we recommend you migrate to a different SOAP engine, such as Apache Axis 2/Java. Alternatively you could use a build of Axis with the patch from https://github.com/apache/ax
Sources
- CVE.orgVulnerability recordCVE-2023-51441
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2023-51441
30-day exploitation probability 1.21%
first.org - Trivy Vulnerability DBPackage advisoryDEBIAN-CVE-2023-51441
** UNSUPPORTED WHEN ASSIGNED ** Improper Input Validation vulnerability in Apache Axis allowed users with access to the admin service to perform possible SSRF This issue affects Apache Axis: through 1.3. As Axis 1 has been EOL we recommend you migrate to a different SOAP engine,
osv.dev
References
Freshness
Last verified in this catalog Nov 6, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 6, 2026
- CVE.orgOct 25, 2026
- Trivy Vulnerability DBOct 25, 2026