Vulnerability · CVE-2024-10190
Horovod Vulnerable to Command Injection
Published Mar 20, 2025 · catalog updated Oct 27, 2026 · Horovod Vulnerable to Command
Last checked Nov 5, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2024-10190. EPSS is 1.12%. Act only if a listed version of Horovod Vulnerable to Command is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Horovod Vulnerable to Command).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- Critical9.8
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 1.12%
- Remediation
- Advisory link
- Affected products
- PyPI horovod
Horovod versions up to and including v0.28.1 are vulnerable to unauthenticated remote code execution. The vulnerability is due to improper handling of base64-encoded data in the , a subclass of . Specifically, the method in calls , which eventually invokes . This allows an attacker to send a malicious pickle object via a PUT request, leading to arbitrary code execution on the server.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- PyPI horovod0 → 0.28.1
How to fix CVE-2024-10190
Upgrade
CVE-2024-10190 lists a fix boundary at 0.28.1. Compare the installed build with that boundary before you change production.
Version check
Fixed in 0.28.1
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2024-10190. EPSS is 1.12%. Act only if a listed version of Horovod Vulnerable to Command is installed.
Which versions are affected?
Compare what you have installed with 0 → 0.28.1. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-502: Deserialization of Untrusted Data; CWE-77: Command Injection. EPSS 1.12%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Mar 20, 2025 · PyPA Advisory Database
Detected
Horovod versions up to and including v0.28.1 are vulnerable to unauthenticated remote code execution. The vulnerability is due to improper handling of base64-encoded data in the , a subclass of . Specifically, the method in calls , which eventually invokes . This allows an attacker to send a malicious pickle object via a PUT request, leading to arbitrary code execution on the server.
Oct 27, 2026 · PyPA Advisory Database
Fix available
horovod fixed in 0.28.1
Oct 27, 2026 · PyPA Advisory Database
Updated
Horovod versions up to and including v0.28.1 are vulnerable to unauthenticated remote code execution. The vulnerability is due to improper handling of base64-encoded data in the , a subclass of . Specifically, the method in calls , which eventually invokes . This allows an attacker to send a malicious pickle object via a PUT request, leading to arbitrary code execution on the server.
Sources
- CVE.orgVulnerability recordCVE-2024-10190
Official CVE identifier
cve.org - PyPA Advisory DatabasePackage advisoryGHSA-mrhh-3ggq-23p2
Horovod Vulnerable to Command Injection
osv.dev
References
Freshness
Last verified in this catalog Nov 5, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- PyPA Advisory DatabaseOct 28, 2026
- CVE.orgOct 27, 2026