Vulnerability · CVE-2024-23730
sync 2026-10-27T17:29:59Z
Published Jan 21, 2024 · catalog updated Oct 27, 2026 · sync 2026-10-27T17:29:59Z
Last checked Nov 5, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2024-23730. EPSS is 1.20%. Act only if a listed version of sync 2026-10-27T17:29:59Z is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (sync 2026-10-27T17:29:59Z).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- Critical9.8
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 1.20%
- Remediation
- Version ranges on file
- Affected products
- PyPI llama-hub · stated named in the record
The OpenAPI and ChatGPT plugin loaders in LlamaHub (aka llama-hub) before 0.0.67 allow attackers to execute arbitrary code because safe_load is not used for YAML." -date: "2025-05-30" +date: "2026-10-27" pubdate: "2024-01-21" affected_range: "<0.0.67" fixed_versions: @@ -19,11 +19,12 @@ solution: "Upgrade to version 0.0.67 or above." urls: - "https://nvd.nist.gov/vuln/detail/CVE-2024-23730" - "htt
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- PyPI llama-hub0 → 0.0.67
- stated named in the record< 0.0.67
How to fix CVE-2024-23730
Upgrade
CVE-2024-23730 lists a fix boundary at 0.0.67. Compare the installed build with that boundary before you change production.
Version check
Affected < 0.0.67
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2024-23730. EPSS is 1.20%. Act only if a listed version of sync 2026-10-27T17:29:59Z is installed.
Which versions are affected?
Compare what you have installed with named in the record < 0.0.67. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-502: Deserialization of Untrusted Data. EPSS 1.20%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Oct 27, 2026 · PyPA Advisory Database
Fix available
llama-hub fixed in 0.0.67
Oct 27, 2026 · PyPA Advisory Database
Fix available
llama-hub fixed in 0.0.67
Oct 27, 2026 · PyPA Advisory Database
Updated
The OpenAPI and ChatGPT plugin loaders in LlamaHub (aka llama-hub) before 0.0.67 allow attackers to execute arbitrary code because safe_load is not used for YAML.
Oct 27, 2026 · GitLab Advisory Database
Detected
The OpenAPI and ChatGPT plugin loaders in LlamaHub (aka llama-hub) before 0.0.67 allow attackers to execute arbitrary code because safe_load is not used for YAML." -date: "2025-05-30" +date: "2026-10-27" pubdate: "2024-01-21" affected_range: "<0.0.67" fixed_versions: @@ -19,11 +19,12 @@ solution: "Upgrade to version 0.0.67 or above." urls: - "https://nvd.nist.gov/vuln/detail/CVE-2024-23730" - "htt
Sources
- CVE.orgVulnerability recordCVE-2024-23730
Official CVE identifier
cve.org - GitLab Advisory DatabasePackage advisorypypi/llama-hub/CVE-2024-23730.yml
The OpenAPI and ChatGPT plugin loaders in LlamaHub (aka llama-hub) before 0.0.67 allow attackers to execute arbitrary code because safe_load is not used for YAML." -date: "2025-05-30" +date: "2026-10-27" pubdate: "2024-01-21" affected_range: "<0.0.67" fixed_versions: @@ -19,11 +19,12 @@ solution: "Upgrade to version 0.0.67 or above." urls: - "https://nvd.nist.gov/vuln/detail/CVE-2024-23730" - "htt
gitlab.com - PyPA Advisory DatabasePackage advisoryGHSA-297x-2qf3-jrj3
Unsafe yaml deserialization in llama-hub
osv.dev
References
Freshness
Last verified in this catalog Nov 5, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- PyPA Advisory DatabaseOct 28, 2026
- CVE.orgOct 27, 2026
- GitLab Advisory DatabaseOct 27, 2026