Vulnerability · CVE-2024-24549
Denial of Service due to improper input validation vulnerability for HTTP/2 requests in Apache Tomcat.
Published Mar 13, 2024 · catalog updated Jun 17, 2026 · Denial of Service due
Last checked Nov 4, 2026. A connected source was read within the last 7 days.
Check this week
CVE-2024-24549 is not in CISA KEV. FIRST estimates a 23.07% chance of exploitation in the next 30 days. Check whether you run Denial of Service due.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Denial of Service due).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-73180 · Medium
- CVE-2026-68763 · High
- CVE-2026-68569 · High
- CVE-2026-68525 · Critical
- CVE-2026-66422 · High
- Severity
- High7.5
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 23.07%
- Remediation
- Version ranges on file
- Affected products
- cpe apache/tomcat
Denial of Service due to improper input validation vulnerability for HTTP/2 requests in Apache Tomcat. When processing an HTTP/2 request, if the request exceeded any of the configured limits for headers, the associated HTTP/2 stream was not reset until after all of the headers had been processed.This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M16, from 10.1.0-M1 through 10.1.18, from 9.0.0-M1 through 9.0.85, from 8.5.0 through 8.5.98. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M17, 10.1.19, 9.0.86 or 8.5.99 which fix the issue.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe apache/tomcat11.0.0
- cpe apache/tomcat< 10.1.19
- cpe apache/tomcat< 8.5.99
- cpe apache/tomcat< 9.0.86
How to fix CVE-2024-24549
Upgrade
CVE-2024-24549 lists a fix boundary at 10.1.19. Compare the installed build with that boundary before you change production.
Version check
Affected < 10.1.19
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
CVE-2024-24549 is not in CISA KEV. FIRST estimates a 23.07% chance of exploitation in the next 30 days. Check whether you run Denial of Service due.
Which versions are affected?
Compare what you have installed with 11.0.0, < 10.1.19, < 8.5.99, < 9.0.86. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-20: Improper Input Validation. EPSS 23.07%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Mar 13, 2024 · Monitored products — critical
Detected
Denial of Service due to improper input validation vulnerability for HTTP/2 requests in Apache Tomcat. When processing an HTTP/2 request, if the request exceeded any of the configured limits for headers, the associated HTTP/2 stream was not reset until after all of the headers had been processed.This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M16, from 10.1.0-M1 through 10.1.18, fr
Jun 17, 2026 · Monitored products — critical
Updated
Denial of Service due to improper input validation vulnerability for HTTP/2 requests in Apache Tomcat. When processing an HTTP/2 request, if the request exceeded any of the configured limits for headers, the associated HTTP/2 stream was not reset until after all of the headers had been processed.This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M16, from 10.1.0-M1 through 10.1.18, fr
Sources
- CVE.orgVulnerability recordCVE-2024-24549
Official CVE identifier
cve.org - Monitored products — criticalVendor advisoryCVE-2024-24549
Denial of Service due to improper input validation vulnerability for HTTP/2 requests in Apache Tomcat. When processing an HTTP/2 request, if the request exceeded any of the configured limits for headers, the associated HTTP/2 stream was not reset until after all of the headers had been processed.This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M16, from 10.1.0-M1 through 10.1.18, fr
nvd.nist.gov
References
Freshness
Last verified in this catalog Nov 3, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgNov 4, 2026
- Monitored products — criticalNov 3, 2026