Vulnerability · CVE-2024-24812
Frappe is a full-stack web application framework that uses Python and MariaDB on the server side and a tightly integrated client side library.
Published Feb 7, 2024 · catalog updated Jun 17, 2026 · Frappe is a full-stack
Last checked Nov 5, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2024-24812. EPSS is 0.38%. Act only if a listed version of Frappe is a full-stack is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Frappe is a full-stack).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-119145 · Critical
- CVE-2026-111388 · Medium
- CVE-2026-81731 · Medium
- CVE-2026-3837 · Medium
- CVE-2026-3673 · Medium
- Severity
- Medium5.4
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.38%
- Remediation
- Version ranges on file
- Affected products
- cpe frappe/frappe
Frappe is a full-stack web application framework that uses Python and MariaDB on the server side and a tightly integrated client side library. Prior to versions 14.59.0 and 15.5.0, portal pages are susceptible to Cross-Site Scripting (XSS) which can be used to inject malicious JS code if user clicks on a malicious link. This vulnerability has been patched in versions 14.59.0 and 15.5.0. No known workarounds are available.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe frappe/frappe< 14.59.0
- cpe frappe/frappe< 15.5.0
How to fix CVE-2024-24812
Upgrade
CVE-2024-24812 lists a fix boundary at 14.59.0. Compare the installed build with that boundary before you change production.
Version check
Affected < 14.59.0
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2024-24812. EPSS is 0.38%. Act only if a listed version of Frappe is a full-stack is installed.
Which versions are affected?
Compare what you have installed with < 14.59.0, < 15.5.0. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-79: Cross-site Scripting (XSS); CWE-80: Basic XSS. EPSS 0.38%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Feb 7, 2024 · Monitored products — high
Detected
Frappe is a full-stack web application framework that uses Python and MariaDB on the server side and a tightly integrated client side library. Prior to versions 14.59.0 and 15.5.0, portal pages are susceptible to Cross-Site Scripting (XSS) which can be used to inject malicious JS code if user clicks on a malicious link. This vulnerability has been patched in versions 14.59.0 and 15.5.0. No known w
Jun 17, 2026 · Monitored products — high
Updated
Frappe is a full-stack web application framework that uses Python and MariaDB on the server side and a tightly integrated client side library. Prior to versions 14.59.0 and 15.5.0, portal pages are susceptible to Cross-Site Scripting (XSS) which can be used to inject malicious JS code if user clicks on a malicious link. This vulnerability has been patched in versions 14.59.0 and 15.5.0. No known w
Sources
- CVE.orgVulnerability recordCVE-2024-24812
Official CVE identifier
cve.org - Monitored products — highVendor advisoryCVE-2024-24812
Frappe is a full-stack web application framework that uses Python and MariaDB on the server side and a tightly integrated client side library. Prior to versions 14.59.0 and 15.5.0, portal pages are susceptible to Cross-Site Scripting (XSS) which can be used to inject malicious JS code if user clicks on a malicious link. This vulnerability has been patched in versions 14.59.0 and 15.5.0. No known w
nvd.nist.gov
References
Freshness
Last verified in this catalog Nov 5, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgNov 5, 2026
- Monitored products — highNov 5, 2026