Vulnerabilities

Vulnerability · CVE-2024-25621

containerd is an open-source container runtime.

Published Nov 6, 2025 · catalog updated Nov 6, 2025 · containerd is an open-source

Last checked Oct 28, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2024-25621. EPSS is 0.17%. Act only if a listed version of containerd is an open-source is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (containerd is an open-source).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
High7.3
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.17%
Remediation
Version ranges on file
Affected products
vendor containerd containerd 2.2.0-beta.0, < 2.2.0

containerd is an open-source container runtime. Versions 0.1.0 through 1.7.28, 2.0.0-beta.0 through 2.0.6, 2.1.0-beta.0 through 2.1.4 and 2.2.0-beta.0 through 2.2.0-rc.1 have an overly broad default permission vulnerability. Directory paths , and were all created with incorrect permissions. This issue is fixed in versions 1.7.29, 2.0.7, 2.1.5 and 2.2.0. Workarounds include updating system administrator permissions so the host can manually chmod the directories to not have group or world accessible permissions, or to run containerd in rootless mode.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • vendor containerd containerd 2.2.0-beta.0, < 2.2.02.2.0-beta.0, < 2.2.0

How to fix CVE-2024-25621

  • Upgrade

    CVE-2024-25621 lists a fix boundary at 2.2.0. Compare the installed build with that boundary before you change production.

  • Version check

    Affected < 2.2.0

  • Advisory

    Open the cve_org record and follow its fix.

  • Official advisories

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2024-25621. EPSS is 0.17%. Act only if a listed version of containerd is an open-source is installed.

Which versions are affected?

Compare what you have installed with containerd containerd 2.2.0-beta.0, < 2.2.0 2.2.0-beta.0, < 2.2.0. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 0.17%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Nov 6, 2025 · EUVD

    Detected

    containerd is an open-source container runtime. Versions 0.1.0 through 1.7.28, 2.0.0-beta.0 through 2.0.6, 2.1.0-beta.0 through 2.1.4 and 2.2.0-beta.0 through 2.2.0-rc.1 have an overly broad default permission vulnerability. Directory paths , and were all created with incorrect permissions. This issue is fixed in versions 1.7.29, 2.0.7, 2.1.5 and 2.2.0. Workarounds include updating system administ

  2. Nov 6, 2025 · EUVD

    Updated

    containerd is an open-source container runtime. Versions 0.1.0 through 1.7.28, 2.0.0-beta.0 through 2.0.6, 2.1.0-beta.0 through 2.1.4 and 2.2.0-beta.0 through 2.2.0-rc.1 have an overly broad default permission vulnerability. Directory paths , and were all created with incorrect permissions. This issue is fixed in versions 1.7.29, 2.0.7, 2.1.5 and 2.2.0. Workarounds include updating system administ

Sources

  • CVE.orgVulnerability recordCVE-2024-25621

    Official CVE identifier

    cve.org
  • EUVDVulnerability recordEUVD-2024-22942

    containerd is an open-source container runtime. Versions 0.1.0 through 1.7.28, 2.0.0-beta.0 through 2.0.6, 2.1.0-beta.0 through 2.1.4 and 2.2.0-beta.0 through 2.2.0-rc.1 have an overly broad default permission vulnerability. Directory paths , and were all created with incorrect p

    euvd.enisa.europa.eu

References

Freshness

Last verified in this catalog Oct 28, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • CVE.orgOct 25, 2026
  • EUVDOct 25, 2026