Vulnerability · CVE-2024-27444
LangChain Experimental vulnerable to arbitrary code execution
Published Feb 26, 2024 · catalog updated Oct 27, 2026 · LangChain Experimental vulnerable to
Last checked Nov 5, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2024-27444. EPSS is 0.77%. Act only if a listed version of LangChain Experimental vulnerable to is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (LangChain Experimental vulnerable to).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- Critical9.8
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.77%
- Remediation
- Advisory link
- Affected products
- PyPI langchain-experimental
langchain_experimental (aka LangChain Experimental) before 0.0.52, part of LangChain before 0.1.8, allows an attacker to bypass the CVE-2023-44467 fix and execute arbitrary code via the , , , , , , , or attribute in Python code. These are not prohibited by .
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- PyPI langchain-experimental0 → 0.0.52
How to fix CVE-2024-27444
Upgrade
CVE-2024-27444 lists a fix boundary at 0.0.52. Compare the installed build with that boundary before you change production.
Version check
Fixed in 0.0.52
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2024-27444. EPSS is 0.77%. Act only if a listed version of LangChain Experimental vulnerable to is installed.
Which versions are affected?
Compare what you have installed with 0 → 0.0.52. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-749. EPSS 0.77%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Feb 26, 2024 · PyPA Advisory Database
Detected
langchain_experimental (aka LangChain Experimental) before 0.0.52, part of LangChain before 0.1.8, allows an attacker to bypass the CVE-2023-44467 fix and execute arbitrary code via the , , , , , , , or attribute in Python code. These are not prohibited by .
Oct 27, 2026 · PyPA Advisory Database
Fix available
langchain-experimental fixed in 0.0.52
Oct 27, 2026 · PyPA Advisory Database
Fix available
langchain-experimental fixed in 0.0.52
Oct 27, 2026 · PyPA Advisory Database
Updated
langchain_experimental (aka LangChain Experimental) before 0.0.52, part of LangChain before 0.1.8, allows an attacker to bypass the CVE-2023-44467 fix and execute arbitrary code via the , , , , , , , or attribute in Python code. These are not prohibited by .
Sources
- CVE.orgVulnerability recordCVE-2024-27444
Official CVE identifier
cve.org - PyPA Advisory DatabasePackage advisoryGHSA-v8vj-cv27-hjv8
LangChain Experimental vulnerable to arbitrary code execution
osv.dev
References
Freshness
Last verified in this catalog Nov 5, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgOct 27, 2026
- PyPA Advisory DatabaseOct 27, 2026