Vulnerability · CVE-2024-3098
sync 2026-10-27T17:30:59Z
Published Apr 10, 2024 · catalog updated Oct 27, 2026 · sync 2026-10-27T17:30:59Z
Last checked Nov 5, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2024-3098. EPSS is 0.96%. Act only if a listed version of sync 2026-10-27T17:30:59Z is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (sync 2026-10-27T17:30:59Z).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- Critical9.8
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.96%
- Remediation
- Version ranges on file
- Affected products
- PyPI llama-index-core · stated named in the record
A vulnerability was identified in the class of the package, specifically within the function, allowing for prompt injection leading to arbitrary code execution. This issue arises due to insufficient validation of input, which can be exploited to bypass method restrictions and execute unauthorized code. The vulnerability is a bypass of the previously addressed CVE-2023-39662, demonstrated through a proof of concept that creates a file on the system by exploiting the flaw.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- PyPI llama-index-core0 → 0.10.24
- stated named in the record< 0.10.24
How to fix CVE-2024-3098
Upgrade
CVE-2024-3098 lists a fix boundary at 0.10.24. Compare the installed build with that boundary before you change production.
Version check
Affected < 0.10.24
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2024-3098. EPSS is 0.96%. Act only if a listed version of sync 2026-10-27T17:30:59Z is installed.
Which versions are affected?
Compare what you have installed with named in the record < 0.10.24. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-94: Code Injection. EPSS 0.96%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Oct 27, 2026 · PyPA Advisory Database
Fix available
llama-index-core fixed in 0.10.24
Oct 27, 2026 · PyPA Advisory Database
Fix available
llama-index-core fixed in 0.10.24
Oct 27, 2026 · PyPA Advisory Database
Updated
A vulnerability was identified in the class of the package, specifically within the function, allowing for prompt injection leading to arbitrary code execution. This issue arises due to insufficient validation of input, which can be exploited to bypass method restrictions and execute unauthorized code. The vulnerability is a bypass of the previously addressed CVE-2023-39662, demonstrated through a
Oct 27, 2026 · GitLab Advisory Database
Detected
A vulnerability was identified in the class of the `l code. The vulnerability is a bypass of the previously addressed CVE-2023-39662, demonstrated through a proof of concept that creates a file on the system by exploiting the flaw." -date: "2024-04-10" +date: "2026-10-27" pubdate: "2024-04-10" affected_range: "<0.10.24" fixed_versions: @@ -24,10 +24,11 @@ solution: "Upgrade to version 0.10.24 or a
Sources
- CVE.orgVulnerability recordCVE-2024-3098
Official CVE identifier
cve.org - GitLab Advisory DatabasePackage advisorypypi/llama-index-core/CVE-2024-3098.yml
A vulnerability was identified in the class of the `l code. The vulnerability is a bypass of the previously addressed CVE-2023-39662, demonstrated through a proof of concept that creates a file on the system by exploiting the flaw." -date: "2024-04-10" +date: "2026-10-27" pubdate: "2024-04-10" affected_range: "<0.10.24" fixed_versions: @@ -24,10 +24,11 @@ solution: "Upgrade to version 0.10.24 or a
gitlab.com - PyPA Advisory DatabasePackage advisoryGHSA-wvpx-g427-q9wc
llama-index-core Prompt Injection vulnerability leading to Arbitrary Code Execution
osv.dev
References
Freshness
Last verified in this catalog Nov 5, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- PyPA Advisory DatabaseOct 28, 2026
- CVE.orgOct 27, 2026
- GitLab Advisory DatabaseOct 27, 2026