Vulnerability · CVE-2024-39331
In Emacs before 29.4, org-link-expand-abbrev in lisp/ol.el expands a %(...) link abbrev even when it specifies an unsafe function, such as shell-command-to-string.
Published Jun 23, 2024 · catalog updated Nov 3, 2026 · In Emacs before 29.4,
Last checked Nov 6, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2024-39331. EPSS is 1.32%. Act only if a listed version of In Emacs before 29.4, is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (In Emacs before 29.4,).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-6861 · High
- Severity
- Critical9.8
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 1.32%
- Remediation
- Version ranges on file
- Affected products
- cpe gnu/emacs
In Emacs before 29.4, org-link-expand-abbrev in lisp/ol.el expands a %(...) link abbrev even when it specifies an unsafe function, such as shell-command-to-string. This affects Org Mode before 9.7.5.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe gnu/emacs< 29.4
How to fix CVE-2024-39331
Upgrade
CVE-2024-39331 lists a fix boundary at 29.4. Compare the installed build with that boundary before you change production.
Version check
Affected < 29.4
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2024-39331. EPSS is 1.32%. Act only if a listed version of In Emacs before 29.4, is installed.
Which versions are affected?
Compare what you have installed with < 29.4. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-94: Code Injection. EPSS 1.32%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Jun 23, 2024 · NIST NVD
Detected
In Emacs before 29.4, org-link-expand-abbrev in lisp/ol.el expands a %(...) link abbrev even when it specifies an unsafe function, such as shell-command-to-string. This affects Org Mode before 9.7.5.
Nov 3, 2026 · NIST NVD
Updated
In Emacs before 29.4, org-link-expand-abbrev in lisp/ol.el expands a %(...) link abbrev even when it specifies an unsafe function, such as shell-command-to-string. This affects Org Mode before 9.7.5.
Sources
- CVE.orgVulnerability recordCVE-2024-39331
Official CVE identifier
cve.org - NIST NVDVulnerability recordCVE-2024-39331
In Emacs before 29.4, org-link-expand-abbrev in lisp/ol.el expands a %(...) link abbrev even when it specifies an unsafe function, such as shell-command-to-string. This affects Org Mode before 9.7.5.
nvd.nist.gov
References
Freshness
Last verified in this catalog Nov 6, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgNov 4, 2026
- NIST NVDNov 4, 2026