Vulnerability · CVE-2024-39877
Apache Airflow 2.4.0, and versions before 2.9.3, has a vulnerability that allows authenticated DAG authors to craft a doc_md parameter in a way that could execute arbi…
Published Jul 17, 2024 · catalog updated Jun 17, 2026 · the affected product
Last checked Nov 2, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2024-39877. EPSS is 1.73%. Act only if a listed version of the affected product is installed.
Gaps on this record
- No plain product name is stored. The page cannot tell you which product to check.
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-82355 · Medium
- CVE-2026-75158 · Medium
- CVE-2026-86473 · Critical
- CVE-2026-68971 · Medium
- CVE-2026-68970 · Medium
- Severity
- High8.8
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 1.73%
- Remediation
- Version ranges on file
- Affected products
- cpe apache/airflow
Apache Airflow 2.4.0, and versions before 2.9.3, has a vulnerability that allows authenticated DAG authors to craft a doc_md parameter in a way that could execute arbitrary code in the scheduler context, which should be forbidden according to the Airflow Security model. Users should upgrade to version 2.9.3 or later which has removed the vulnerability.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe apache/airflow< 2.9.3
How to fix CVE-2024-39877
Upgrade
CVE-2024-39877 lists a fix boundary at 2.9.3. Compare the installed build with that boundary before you change production.
Version check
Affected < 2.9.3
Advisory
Open the inventory_high record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2024-39877. EPSS is 1.73%. Act only if a listed version of the affected product is installed.
Which versions are affected?
Compare what you have installed with < 2.9.3. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-277; CWE-94: Code Injection. EPSS 1.73%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Jul 17, 2024 · Monitored products — high
Detected
Apache Airflow 2.4.0, and versions before 2.9.3, has a vulnerability that allows authenticated DAG authors to craft a doc_md parameter in a way that could execute arbitrary code in the scheduler context, which should be forbidden according to the Airflow Security model. Users should upgrade to version 2.9.3 or later which has removed the vulnerability.
Jun 17, 2026 · Monitored products — high
Updated
Apache Airflow 2.4.0, and versions before 2.9.3, has a vulnerability that allows authenticated DAG authors to craft a doc_md parameter in a way that could execute arbitrary code in the scheduler context, which should be forbidden according to the Airflow Security model. Users should upgrade to version 2.9.3 or later which has removed the vulnerability.
Sources
- Monitored products — highVendor advisoryCVE-2024-39877
Apache Airflow 2.4.0, and versions before 2.9.3, has a vulnerability that allows authenticated DAG authors to craft a doc_md parameter in a way that could execute arbitrary code in the scheduler context, which should be forbidden according to the Airflow Security model. Users should upgrade to version 2.9.3 or later which has removed the vulnerability.
nvd.nist.gov
References
Freshness
Last verified in this catalog Nov 2, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- Monitored products — highNov 2, 2026