Vulnerability · CVE-2024-42360
SequenceServer lets you rapidly set up a BLAST+ server with an intuitive user interface for personal or group use.
Published Aug 14, 2024 · catalog updated Oct 29, 2026 · SequenceServer lets you rapidly
Last checked Nov 7, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2024-42360. EPSS is 0.58%. Act only if a listed version of SequenceServer lets you rapidly is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (SequenceServer lets you rapidly).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- Critical9.8
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.58%
- Remediation
- Version ranges on file
- Affected products
- cpe wurmlab/sequenceserver
SequenceServer lets you rapidly set up a BLAST+ server with an intuitive user interface for personal or group use. Several HTTP endpoints did not properly sanitize user input and/or query parameters. This could be exploited to inject and run unwanted shell commands. This vulnerability has been fixed in 3.1.2.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe wurmlab/sequenceserver< 3.1.2
How to fix CVE-2024-42360
Upgrade
CVE-2024-42360 lists a fix boundary at 3.1.2. Compare the installed build with that boundary before you change production.
Version check
Affected < 3.1.2
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2024-42360. EPSS is 0.58%. Act only if a listed version of SequenceServer lets you rapidly is installed.
Which versions are affected?
Compare what you have installed with < 3.1.2. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-77: Command Injection. EPSS 0.58%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Aug 14, 2024 · NIST NVD
Detected
SequenceServer lets you rapidly set up a BLAST+ server with an intuitive user interface for personal or group use. Several HTTP endpoints did not properly sanitize user input and/or query parameters. This could be exploited to inject and run unwanted shell commands. This vulnerability has been fixed in 3.1.2.
Oct 29, 2026 · NIST NVD
Updated
SequenceServer lets you rapidly set up a BLAST+ server with an intuitive user interface for personal or group use. Several HTTP endpoints did not properly sanitize user input and/or query parameters. This could be exploited to inject and run unwanted shell commands. This vulnerability has been fixed in 3.1.2.
Sources
- CVE.orgVulnerability recordCVE-2024-42360
Official CVE identifier
cve.org - NIST NVDVulnerability recordCVE-2024-42360
SequenceServer lets you rapidly set up a BLAST+ server with an intuitive user interface for personal or group use. Several HTTP endpoints did not properly sanitize user input and/or query parameters. This could be exploited to inject and run unwanted shell commands. This vulnerab
nvd.nist.gov
References
Freshness
Last verified in this catalog Nov 7, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgOct 29, 2026
- NIST NVDOct 29, 2026