Security fix · CVE-2024-43796
express vulnerable to XSS via response.redirect()
Published Sep 10, 2024 · catalog updated Sep 10, 2024 · express vulnerable to XSS
Last checked Nov 5, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2024-43796. EPSS is 0.49%. Act only if a listed version of express vulnerable to XSS is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (express vulnerable to XSS).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- Medium5.0
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.49%
- Remediation
- Version ranges on file
- Affected products
- npm express
### Impact In express <4.20.0, passing untrusted user input - even after sanitizing it - to may execute untrusted code ### Patches this issue is patched in express 4.20.0 ### Workarounds users are encouraged to upgrade to the patched version of express, but otherwise can workaround this issue by making sure any untrusted inputs are safe, ideally by validating them against an explicit allowlist ### Details successful exploitation of this vector requires the following: 1. The attacker MUST control the input to response.redirect() 1. express MUST NOT redirect before the template appears 1. the browser MUST NOT complete redirection before: 1. the user MUST click on the link in the template
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- npm express<4.20.0
- npm express>=5.0.0-alpha.1, <5.0.0
How to fix CVE-2024-43796
Upgrade
CVE-2024-43796 lists a fix boundary at 4.20.0. Compare the installed build with that boundary before you change production.
Version check
Affected <4.20.0
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2024-43796. EPSS is 0.49%. Act only if a listed version of express vulnerable to XSS is installed.
Which versions are affected?
Compare what you have installed with <4.20.0, >=5.0.0-alpha.1, <5.0.0. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-79: Cross-site Scripting (XSS). EPSS 0.49%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Sep 10, 2024 · Maintainer security tabs
Detected
### Impact In express <4.20.0, passing untrusted user input - even after sanitizing it - to may execute untrusted code ### Patches this issue is patched in express 4.20.0 ### Workarounds users are encouraged to upgrade to the patched version of express, but otherwise can workaround this issue by making sure any untrusted inputs are safe, ideally by validating them against an explicit allowlist ###
Sources
- CVE.orgVulnerability recordCVE-2024-43796
Official CVE identifier
cve.org - Maintainer security tabsVendor advisoryGHSA-qw6h-vgh9-j6wx
### Impact In express <4.20.0, passing untrusted user input - even after sanitizing it - to may execute untrusted code ### Patches this issue is patched in express 4.20.0 ### Workarounds users are encouraged to upgrade to the patched version of express, but otherwise can workaround this issue by making sure any untrusted inputs are safe, ideally by validating them against an explicit allowlist ###
github.com
Freshness
Last verified in this catalog Nov 5, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgNov 4, 2026
- Maintainer security tabsNov 2, 2026