Vulnerabilities

Vulnerability · CVE-2024-45784

Apache Airflow versions before 2.10.3 contain a vulnerability that could expose sensitive configuration variables in task logs.

Published Nov 15, 2024 · catalog updated Jun 17, 2026 · Apache Airflow versions before

Last checked Nov 2, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2024-45784. EPSS is 1.34%. Act only if a listed version of Apache Airflow versions before is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (Apache Airflow versions before).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
High7.5
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
1.34%
Remediation
Version ranges on file
Affected products
cpe apache/airflow

Apache Airflow versions before 2.10.3 contain a vulnerability that could expose sensitive configuration variables in task logs. This vulnerability allows DAG authors to unintentionally or intentionally log sensitive configuration variables. Unauthorized users could access these logs, potentially exposing critical data that could be exploited to compromise the security of the Airflow deployment. In version 2.10.3, secrets are now masked in task logs to prevent sensitive configuration variables from being exposed in the logging output. Users should upgrade to Airflow 2.10.3 or the latest version to eliminate this vulnerability. If you suspect that DAG authors could have logged the secret values to the logs and that your logs are not additionally protected, it is also recommended that you update those secrets.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • cpe apache/airflow< 2.10.3

How to fix CVE-2024-45784

  • Upgrade

    CVE-2024-45784 lists a fix boundary at 2.10.3. Compare the installed build with that boundary before you change production.

  • Version check

    Affected < 2.10.3

  • Advisory

    Open the inventory_high record and follow its fix.

  • Official advisories

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2024-45784. EPSS is 1.34%. Act only if a listed version of Apache Airflow versions before is installed.

Which versions are affected?

Compare what you have installed with < 2.10.3. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

CWE-1295. EPSS 1.34%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Nov 15, 2024 · Monitored products — high

    Detected

    Apache Airflow versions before 2.10.3 contain a vulnerability that could expose sensitive configuration variables in task logs. This vulnerability allows DAG authors to unintentionally or intentionally log sensitive configuration variables. Unauthorized users could access these logs, potentially exposing critical data that could be exploited to compromise the security of the Airflow deployment. In

  2. Jun 17, 2026 · Monitored products — high

    Updated

    Apache Airflow versions before 2.10.3 contain a vulnerability that could expose sensitive configuration variables in task logs. This vulnerability allows DAG authors to unintentionally or intentionally log sensitive configuration variables. Unauthorized users could access these logs, potentially exposing critical data that could be exploited to compromise the security of the Airflow deployment. In

Sources

  • Monitored products — highVendor advisoryCVE-2024-45784

    Apache Airflow versions before 2.10.3 contain a vulnerability that could expose sensitive configuration variables in task logs. This vulnerability allows DAG authors to unintentionally or intentionally log sensitive configuration variables. Unauthorized users could access these logs, potentially exposing critical data that could be exploited to compromise the security of the Airflow deployment. In

    nvd.nist.gov

References

Freshness

Last verified in this catalog Nov 2, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • Monitored products — highNov 2, 2026