Vulnerabilities

Security fix · CVE-2024-49364

tiny-secp256k1 is a tiny secp256k1 native/JS wrapper.

Published Jul 1, 2025 · catalog updated Jul 1, 2025 · tiny-secp256k1 is a tiny

Last checked Oct 27, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2024-49364. EPSS is 0.36%. Act only if a listed version of tiny-secp256k1 is a tiny is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (tiny-secp256k1 is a tiny).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
High8.1
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.36%
Remediation
Version ranges on file
Affected products
vendor bitcoinjs tiny-secp256k1 < 1.1.7

tiny-secp256k1 is a tiny secp256k1 native/JS wrapper. Prior to version 1.1.7, a private key can be extracted on signing a malicious JSON-stringifiable object, when global Buffer is the buffer package. This affects only environments where require('buffer') is the NPM buffer package. The Buffer.isBuffer check can be bypassed, resulting in k reuse for different messages, leading to private key extraction over a single invalid message (and a second one for which any message/signature could be taken, e.g. previously known valid one). This issue has been patched in version 1.1.7.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • vendor bitcoinjs tiny-secp256k1 < 1.1.7< 1.1.7

How to fix CVE-2024-49364

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2024-49364. EPSS is 0.36%. Act only if a listed version of tiny-secp256k1 is a tiny is installed.

Which versions are affected?

Compare what you have installed with bitcoinjs tiny-secp256k1 < 1.1.7 < 1.1.7. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 0.36%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Jul 1, 2025 · EUVD

    Detected

    tiny-secp256k1 is a tiny secp256k1 native/JS wrapper. Prior to version 1.1.7, a private key can be extracted on signing a malicious JSON-stringifiable object, when global Buffer is the buffer package. This affects only environments where require('buffer') is the NPM buffer package. The Buffer.isBuffer check can be bypassed, resulting in k reuse for different messages, leading to private key extrac

  2. Jul 1, 2025 · EUVD

    Updated

    tiny-secp256k1 is a tiny secp256k1 native/JS wrapper. Prior to version 1.1.7, a private key can be extracted on signing a malicious JSON-stringifiable object, when global Buffer is the buffer package. This affects only environments where require('buffer') is the NPM buffer package. The Buffer.isBuffer check can be bypassed, resulting in k reuse for different messages, leading to private key extrac

Sources

  • CVE.orgVulnerability recordCVE-2024-49364

    Official CVE identifier

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2024-49364

    30-day exploitation probability 0.36%

    first.org
  • EUVDVulnerability recordEUVD-2024-54990

    tiny-secp256k1 is a tiny secp256k1 native/JS wrapper. Prior to version 1.1.7, a private key can be extracted on signing a malicious JSON-stringifiable object, when global Buffer is the buffer package. This affects only environments where require('buffer') is the NPM buffer packag

    euvd.enisa.europa.eu

References

Freshness

Last verified in this catalog Oct 27, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • FIRST EPSSOct 24, 2026
  • CVE.orgOct 21, 2026
  • EUVDOct 20, 2026