Vulnerability · CVE-2024-52279
Improper Input Validation vulnerability in Apache Zeppelin.
Published Aug 3, 2025 · catalog updated Nov 4, 2025 · Apache Software Foundation Apache Zeppelin
Last checked Oct 27, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2024-52279. EPSS is 1.05%. Act only if a listed version of Apache Software Foundation Apache Zeppelin is installed.
Gaps on this record
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2024-51775 · High
- CVE-2024-41177 · Medium
- Severity
- High7.5
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 1.05%
- Remediation
- Version ranges on file
- Affected products
- vendor Apache Software Foundation Apache Zeppelin 0.11.1 <0.12.0
Improper Input Validation vulnerability in Apache Zeppelin. The fix for JDBC URL validation in CVE-2024-31864 did not account for URL encoded input. This issue affects Apache Zeppelin: from 0.11.1 before 0.12.0. Users are recommended to upgrade to version 0.12.0, which fixes the issue.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor Apache Software Foundation Apache Zeppelin 0.11.1 <0.12.00.11.1 <0.12.0
How to fix CVE-2024-52279
Upgrade
CVE-2024-52279 lists a fix boundary at 0.12.0. Compare the installed build with that boundary before you change production.
Version check
Seen in 0.11.1 <0.12.0
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2024-52279. EPSS is 1.05%. Act only if a listed version of Apache Software Foundation Apache Zeppelin is installed.
Which versions are affected?
Compare what you have installed with Apache Software Foundation Apache Zeppelin 0.11.1 <0.12.0 0.11.1 <0.12.0. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 1.05%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Aug 3, 2025 · EUVD
Detected
Improper Input Validation vulnerability in Apache Zeppelin. The fix for JDBC URL validation in CVE-2024-31864 did not account for URL encoded input. This issue affects Apache Zeppelin: from 0.11.1 before 0.12.0. Users are recommended to upgrade to version 0.12.0, which fixes the issue.
Nov 4, 2025 · EUVD
Updated
Improper Input Validation vulnerability in Apache Zeppelin. The fix for JDBC URL validation in CVE-2024-31864 did not account for URL encoded input. This issue affects Apache Zeppelin: from 0.11.1 before 0.12.0. Users are recommended to upgrade to version 0.12.0, which fixes the issue.
Sources
- CVE.orgVulnerability recordCVE-2024-52279
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2024-52279
30-day exploitation probability 1.05%
first.org - EUVDVulnerability recordEUVD-2024-54846
Improper Input Validation vulnerability in Apache Zeppelin. The fix for JDBC URL validation in CVE-2024-31864 did not account for URL encoded input. This issue affects Apache Zeppelin: from 0.11.1 before 0.12.0. Users are recommended to upgrade to version 0.12.0, which fixes the
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Oct 27, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSOct 27, 2026
- CVE.orgOct 21, 2026
- EUVDOct 20, 2026