Vulnerability · CVE-2025-10475
A weakness has been identified in SpyShelter up to 15.4.0.1015.
Published Sep 15, 2025 · catalog updated Oct 19, 2026 · SpyShelter
Last checked Oct 27, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-10475. EPSS is 0.15%. Act only if a listed version of SpyShelter is installed.
Gaps on this record
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- Medium6.8
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.15%
- Remediation
- Vendor / distro source
- Affected products
- vendor n/a SpyShelter 15.4.0.1015
A weakness has been identified in SpyShelter up to 15.4.0.1015. Affected is an unknown function in the library SpyShelter.sys of the component IOCTL Handler. This manipulation causes denial of service. The attack needs to be launched locally. The exploit has been made available to the public and could be exploited. Upgrading to version 15.4.0.1028 is able to address this issue. It is advisable to upgrade the affected component.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor n/a SpyShelter 15.4.0.101515.4.0.1015
How to fix CVE-2025-10475
No stored fix
No vendor fix text is stored. Use the linked advisory before you change production.
Version check
Seen in 15.4.0.1015
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-10475. EPSS is 0.15%. Act only if a listed version of SpyShelter is installed.
Which versions are affected?
Compare what you have installed with n/a SpyShelter 15.4.0.1015 15.4.0.1015. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-404. EPSS 0.15%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Sep 15, 2025 · NIST NVD
Detected
A weakness has been identified in SpyShelter up to 15.4.0.1015. Affected is an unknown function in the library SpyShelter.sys of the component IOCTL Handler. This manipulation causes denial of service. The attack needs to be launched locally. The exploit has been made available to the public and could be exploited. Upgrading to version 15.4.0.1028 is able to address this issue. It is advisable to
Oct 19, 2026 · NIST NVD
Updated
A weakness has been identified in SpyShelter up to 15.4.0.1015. Affected is an unknown function in the library SpyShelter.sys of the component IOCTL Handler. This manipulation causes denial of service. The attack needs to be launched locally. The exploit has been made available to the public and could be exploited. Upgrading to version 15.4.0.1028 is able to address this issue. It is advisable to
Sources
- CVE.orgVulnerability recordCVE-2025-10475
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-10475
30-day exploitation probability 0.15%
first.org - EUVDVulnerability recordEUVD-2025-29239
A weakness has been identified in SpyShelter up to 15.4.0.1015. Affected is an unknown function in the library SpyShelter.sys of the component IOCTL Handler. This manipulation causes denial of service. The attack needs to be launched locally. The exploit has been made available t
euvd.enisa.europa.eu - NIST NVDVulnerability recordCVE-2025-10475
A weakness has been identified in SpyShelter up to 15.4.0.1015. Affected is an unknown function in the library SpyShelter.sys of the component IOCTL Handler. This manipulation causes denial of service. The attack needs to be launched locally. The exploit has been made available t
nvd.nist.gov
References
Freshness
Last verified in this catalog Oct 27, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSOct 24, 2026
- EUVDOct 23, 2026
- CVE.orgOct 21, 2026
- NIST NVDOct 19, 2026