Threat intelligence · CVE-2025-11573
An infinite loop issue in Amazon.IonDotnet library versions <v1.3.2 may allow a threat actor to cause a denial of service through a specially crafted text input.
Published Oct 9, 2025 · catalog updated Oct 9, 2025 · Amazon Amazon.IonDotnet
Last checked Nov 4, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-11573. EPSS is 0.43%. Act only if a listed version of Amazon Amazon.IonDotnet is installed.
Gaps on this record
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- High8.7
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.43%
- Remediation
- Version ranges on file
- Affected products
- vendor Amazon Amazon.IonDotnet 0 <1.3.2
An infinite loop issue in Amazon.IonDotnet library versions <v1.3.2 may allow a threat actor to cause a denial of service through a specially crafted text input. To mitigate this issue, users should upgrade to version v1.3.2. As of August 20, 2025, this library has been deprecated and will not receive further updates.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor Amazon Amazon.IonDotnet 0 <1.3.20 <1.3.2
How to fix CVE-2025-11573
Upgrade
CVE-2025-11573 lists a fix boundary at 1.3.2. Compare the installed build with that boundary before you change production.
Version check
Seen in 0 <1.3.2
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-11573. EPSS is 0.43%. Act only if a listed version of Amazon Amazon.IonDotnet is installed.
Which versions are affected?
Compare what you have installed with Amazon Amazon.IonDotnet 0 <1.3.2 0 <1.3.2. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.43%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Oct 9, 2025 · EUVD
Detected
An infinite loop issue in Amazon.IonDotnet library versions <v1.3.2 may allow a threat actor to cause a denial of service through a specially crafted text input. To mitigate this issue, users should upgrade to version v1.3.2. As of August 20, 2025, this library has been deprecated and will not receive further updates.
Oct 9, 2025 · EUVD
Updated
An infinite loop issue in Amazon.IonDotnet library versions <v1.3.2 may allow a threat actor to cause a denial of service through a specially crafted text input. To mitigate this issue, users should upgrade to version v1.3.2. As of August 20, 2025, this library has been deprecated and will not receive further updates.
Sources
- CVE.orgVulnerability recordCVE-2025-11573
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-11573
30-day exploitation probability 0.43%
first.org - EUVDVulnerability recordEUVD-2025-33578
An infinite loop issue in Amazon.IonDotnet library versions <v1.3.2 may allow a threat actor to cause a denial of service through a specially crafted text input. To mitigate this issue, users should upgrade to version v1.3.2. As of August 20, 2025, this library has been deprecate
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Nov 4, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 4, 2026
- CVE.orgOct 23, 2026
- EUVDOct 23, 2026