Vulnerabilities

Vulnerability · CVE-2025-12705

The Social Reviews & Recommendations plugin for WordPress is vulnerable to Stored Cross-Site Scripting via several parameters in the 'trim_text' function in all versions up to, and

Published Dec 9, 2025 · catalog updated Apr 8, 2026 · Reviews Widgets for Google, Yelp & TripAdvisor

Last checked Nov 1, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2025-12705. EPSS is 0.37%. Act only if a listed version of Reviews Widgets for Google, Yelp & TripAdvisor is installed.

Gaps on this record

  • No vendor fix or required action is stored. Compare the linked advisory before you change production.
Severity
High7.2
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.37%
Remediation
Vendor / distro source
Affected products
vendor widgetpack Reviews Widgets for Google, Yelp & TripAdvisor 0 ≤2.5

The Social Reviews & Recommendations plugin for WordPress is vulnerable to Stored Cross-Site Scripting via several parameters in the 'trim_text' function in all versions up to, and including, 2.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 2.5.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • vendor widgetpack Reviews Widgets for Google, Yelp & TripAdvisor 0 ≤2.50 ≤2.5

How to fix CVE-2025-12705

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2025-12705. EPSS is 0.37%. Act only if a listed version of Reviews Widgets for Google, Yelp & TripAdvisor is installed.

Which versions are affected?

Compare what you have installed with widgetpack Reviews Widgets for Google, Yelp & TripAdvisor 0 ≤2.5 0 ≤2.5. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 0.37%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Dec 9, 2025 · EUVD

    Detected

    The Social Reviews & Recommendations plugin for WordPress is vulnerable to Stored Cross-Site Scripting via several parameters in the 'trim_text' function in all versions up to, and including, 2.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an inje

  2. Apr 8, 2026 · EUVD

    Updated

    The Social Reviews & Recommendations plugin for WordPress is vulnerable to Stored Cross-Site Scripting via several parameters in the 'trim_text' function in all versions up to, and including, 2.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an inje

Sources

  • CVE.orgVulnerability recordCVE-2025-12705

    Official CVE identifier

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2025-12705

    30-day exploitation probability 0.37%

    first.org
  • EUVDVulnerability recordEUVD-2025-202052

    The Social Reviews & Recommendations plugin for WordPress is vulnerable to Stored Cross-Site Scripting via several parameters in the 'trim_text' function in all versions up to, and including, 2.5 due to insufficient input sanitization and output escaping. This makes it possible f

    euvd.enisa.europa.eu

References

Freshness

Last verified in this catalog Nov 1, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • FIRST EPSSNov 1, 2026
  • CVE.orgOct 27, 2026
  • EUVDOct 26, 2026