Security fix · CVE-2025-12944
Improper input validation in NETGEAR DGN2200v4 (N300 Wireless ADSL2+ Modem Router) allows attackers with direct network access to the device to potentially execute code on the devi
Published Nov 11, 2025 · catalog updated Feb 26, 2026 · Netgear DGN2200v4
Last checked Nov 2, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-12944. EPSS is 0.27%. Act only if a listed version of Netgear DGN2200v4 is installed.
Gaps on this record
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- Medium6.8
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.27%
- Remediation
- Advisory link
- Affected products
- vendor Netgear DGN2200v4 0 ≤1.0.0.126
Improper input validation in NETGEAR DGN2200v4 (N300 Wireless ADSL2+ Modem Router) allows attackers with direct network access to the device to potentially execute code on the device. Please check the firmware version and update to the latest. Fixed in: DGN2200v4 firmware 1.0.0.132 or later
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor Netgear DGN2200v4 0 ≤1.0.0.1260 ≤1.0.0.126
How to fix CVE-2025-12944
No stored fix
No vendor fix text is stored. Use the linked advisory before you change production.
Version check
Seen in 0 ≤1.0.0.126
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-12944. EPSS is 0.27%. Act only if a listed version of Netgear DGN2200v4 is installed.
Which versions are affected?
Compare what you have installed with Netgear DGN2200v4 0 ≤1.0.0.126 0 ≤1.0.0.126. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.27%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Nov 11, 2025 · EUVD
Detected
Improper input validation in NETGEAR DGN2200v4 (N300 Wireless ADSL2+ Modem Router) allows attackers with direct network access to the device to potentially execute code on the device. Please check the firmware version and update to the latest. Fixed in: DGN2200v4 firmware 1.0.0.132 or later
Feb 26, 2026 · EUVD
Updated
Improper input validation in NETGEAR DGN2200v4 (N300 Wireless ADSL2+ Modem Router) allows attackers with direct network access to the device to potentially execute code on the device. Please check the firmware version and update to the latest. Fixed in: DGN2200v4 firmware 1.0.0.132 or later
Sources
- CVE.orgVulnerability recordCVE-2025-12944
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-12944
30-day exploitation probability 0.27%
first.org - EUVDVulnerability recordEUVD-2025-93538
Improper input validation in NETGEAR DGN2200v4 (N300 Wireless ADSL2+ Modem Router) allows attackers with direct network access to the device to potentially execute code on the device. Please check the firmware version and update to the latest. Fixed in: DGN2200v4 firmware 1.0.0.1
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Nov 2, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 2, 2026
- CVE.orgOct 24, 2026
- EUVDOct 24, 2026