Vulnerabilities

Vulnerability · CVE-2025-13428

A vulnerability exists in the SecOps SOAR server.

Published Dec 9, 2025 · catalog updated Dec 9, 2025 · Google Cloud Google Cloud SecOps SOAR

Last checked Oct 28, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2025-13428. EPSS is 0.33%. Act only if a listed version of Google Cloud Google Cloud SecOps SOAR is installed.

Gaps on this record

  • No vendor fix or required action is stored. Compare the linked advisory before you change production.
Severity
High8.6
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.33%
Remediation
Advisory link
Affected products
vendor Google Cloud Google Cloud SecOps SOAR 0 ≤6.3.64

A vulnerability exists in the SecOps SOAR server. The custom integrations feature allowed an authenticated user with an "IDE role" to achieve Remote Code Execution (RCE) in the server. The flaw stemmed from weak validation of uploaded Python package code. An attacker could upload a package containing a malicious setup.py file, which would execute on the server during the installation process, leading to potential server compromise. No customer action is required. All customers have been automatically upgraded to the fixed version: 6.3.64 or higher.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • vendor Google Cloud Google Cloud SecOps SOAR 0 ≤6.3.640 ≤6.3.64

How to fix CVE-2025-13428

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2025-13428. EPSS is 0.33%. Act only if a listed version of Google Cloud Google Cloud SecOps SOAR is installed.

Which versions are affected?

Compare what you have installed with Google Cloud Google Cloud SecOps SOAR 0 ≤6.3.64 0 ≤6.3.64. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 0.33%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Code

The project this record applies to. Exploit listings stay in References.

No public source repository is identified for this product.

Timeline

Detection, updates, and resolution for this record.

  1. Dec 9, 2025 · EUVD

    Detected

    A vulnerability exists in the SecOps SOAR server. The custom integrations feature allowed an authenticated user with an "IDE role" to achieve Remote Code Execution (RCE) in the server. The flaw stemmed from weak validation of uploaded Python package code. An attacker could upload a package containing a malicious setup.py file, which would execute on the server during the installation process, lead

  2. Dec 9, 2025 · EUVD

    Updated

    A vulnerability exists in the SecOps SOAR server. The custom integrations feature allowed an authenticated user with an "IDE role" to achieve Remote Code Execution (RCE) in the server. The flaw stemmed from weak validation of uploaded Python package code. An attacker could upload a package containing a malicious setup.py file, which would execute on the server during the installation process, lead

Sources

  • CVE.orgVulnerability recordCVE-2025-13428

    Official CVE identifier

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2025-13428

    30-day exploitation probability 0.33%

    first.org
  • EUVDVulnerability recordEUVD-2025-201881

    A vulnerability exists in the SecOps SOAR server. The custom integrations feature allowed an authenticated user with an "IDE role" to achieve Remote Code Execution (RCE) in the server. The flaw stemmed from weak validation of uploaded Python package code. An attacker could upload

    euvd.enisa.europa.eu

References

Freshness

Last verified in this catalog Oct 28, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • FIRST EPSSOct 28, 2026
  • CVE.orgOct 28, 2026
  • EUVDOct 27, 2026