Vulnerability · CVE-2025-14280
The PixelYourSite plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 11.1.5 through publicly exposed log files.
Published Dec 29, 2025 · catalog updated Apr 8, 2026 · PixelYourSite PixelYourSite – Your smart PIXEL (TAG) & API Manager
Last checked Nov 2, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-14280. EPSS is 0.43%. Act only if a listed version of PixelYourSite PixelYourSite – Your smart PIXEL (TAG) & API Manager is installed.
Gaps on this record
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-1841 · High
- CVE-2025-10588 · Medium
- Severity
- Medium5.3
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.43%
- Remediation
- Vendor / distro source
- Affected products
- vendor PixelYourSite PixelYourSite – Your smart PIXEL (TAG) & API Manager 0 ≤11.1.5
The PixelYourSite plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 11.1.5 through publicly exposed log files. This makes it possible for unauthenticated attackers to view potentially sensitive information contained in the exposed log files, when the "Meta API logs" setting is enabled (disabled by default). The vulnerability was partially patched in version 11.1.5 and fully patched in version 11.1.5.1.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor PixelYourSite PixelYourSite – Your smart PIXEL (TAG) & API Manager 0 ≤11.1.50 ≤11.1.5
How to fix CVE-2025-14280
No stored fix
No vendor fix text is stored. Use the linked advisory before you change production.
Version check
Seen in 0 ≤11.1.5
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-14280. EPSS is 0.43%. Act only if a listed version of PixelYourSite PixelYourSite – Your smart PIXEL (TAG) & API Manager is installed.
Which versions are affected?
Compare what you have installed with PixelYourSite PixelYourSite – Your smart PIXEL (TAG) & API Manager 0 ≤11.1.5 0 ≤11.1.5. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.43%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Dec 29, 2025 · EUVD
Detected
The PixelYourSite plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 11.1.5 through publicly exposed log files. This makes it possible for unauthenticated attackers to view potentially sensitive information contained in the exposed log files, when the "Meta API logs" setting is enabled (disabled by default). The vulnerability was partially pa
Apr 8, 2026 · EUVD
Updated
The PixelYourSite plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 11.1.5 through publicly exposed log files. This makes it possible for unauthenticated attackers to view potentially sensitive information contained in the exposed log files, when the "Meta API logs" setting is enabled (disabled by default). The vulnerability was partially pa
Sources
- CVE.orgVulnerability recordCVE-2025-14280
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-14280
30-day exploitation probability 0.43%
first.org - EUVDVulnerability recordEUVD-2025-205634
The PixelYourSite plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 11.1.5 through publicly exposed log files. This makes it possible for unauthenticated attackers to view potentially sensitive information contained in the
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Nov 2, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 2, 2026
- CVE.orgOct 30, 2026
- EUVDOct 30, 2026