Vulnerabilities

Vulnerability · CVE-2025-14507

The EventPrime - Events Calendar, Bookings and Tickets plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 4.2.7.0 via the RE

Published Jan 13, 2026 · catalog updated Apr 8, 2026 · Metagauss EventPrime – Events Calendar, Bookings and Tickets

Last checked Oct 30, 2026. A connected source was read within the last 7 days.

Check this week

CVE-2025-14507 is not in CISA KEV. FIRST estimates a 42.00% chance of exploitation in the next 30 days. Check whether you run Metagauss EventPrime – Events Calendar, Bookings and Tickets.

Gaps on this record

  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
Medium5.3
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
42.00%
Remediation
Vendor / distro source
Affected products
vendor Metagauss EventPrime – Events Calendar, Bookings and Tickets 0 ≤4.2.7.0

The EventPrime - Events Calendar, Bookings and Tickets plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 4.2.7.0 via the REST API. This makes it possible for unauthenticated attackers to extract sensitive booking data including user names, email addresses, ticket details, payment information, and order keys when the API is enabled by an administrator. The vulnerability was partially patched in version 4.2.7.0.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • vendor Metagauss EventPrime – Events Calendar, Bookings and Tickets 0 ≤4.2.7.00 ≤4.2.7.0

How to fix CVE-2025-14507

  • No stored fix

    No vendor fix text is stored. Use the linked advisory before you change production.

  • Version check

    Seen in 0 ≤4.2.7.0

  • Official advisories

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

CVE-2025-14507 is not in CISA KEV. FIRST estimates a 42.00% chance of exploitation in the next 30 days. Check whether you run Metagauss EventPrime – Events Calendar, Bookings and Tickets.

Which versions are affected?

Compare what you have installed with Metagauss EventPrime – Events Calendar, Bookings and Tickets 0 ≤4.2.7.0 0 ≤4.2.7.0. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 42.00%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Jan 13, 2026 · EUVD

    Detected

    The EventPrime - Events Calendar, Bookings and Tickets plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 4.2.7.0 via the REST API. This makes it possible for unauthenticated attackers to extract sensitive booking data including user names, email addresses, ticket details, payment information, and order keys when the API is enabled by an admi

  2. Apr 8, 2026 · EUVD

    Updated

    The EventPrime - Events Calendar, Bookings and Tickets plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 4.2.7.0 via the REST API. This makes it possible for unauthenticated attackers to extract sensitive booking data including user names, email addresses, ticket details, payment information, and order keys when the API is enabled by an admi

Sources

  • EUVDVulnerability recordEUVD-2026-2351

    The EventPrime - Events Calendar, Bookings and Tickets plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 4.2.7.0 via the REST API. This makes it possible for unauthenticated attackers to extract sensitive booking data inclu

    euvd.enisa.europa.eu

References

Freshness

Last verified in this catalog Apr 8, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • EUVDOct 30, 2026