Vulnerabilities

Vulnerability · CVE-2025-14795

The Stop Spammers Classic plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2026.1.

Published Jan 28, 2026 · catalog updated Apr 8, 2026 · Stop Spammers Classic

Last checked Nov 4, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2025-14795. EPSS is 0.18%. Act only if a listed version of Stop Spammers Classic is installed.

Gaps on this record

  • No vendor fix or required action is stored. Compare the linked advisory before you change production.
Severity
Medium4.3
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.18%
Remediation
Vendor / distro source
Affected products
vendor webguyio Stop Spammers Classic 0 ≤2026.1

The Stop Spammers Classic plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2026.1. This is due to missing nonce validation in the ss_addtoallowlist class. This makes it possible for unauthenticated attackers to add arbitrary email addresses to the spam allowlist via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. The vulnerability was partially patched in version 2026.1.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • vendor webguyio Stop Spammers Classic 0 ≤2026.10 ≤2026.1

How to fix CVE-2025-14795

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2025-14795. EPSS is 0.18%. Act only if a listed version of Stop Spammers Classic is installed.

Which versions are affected?

Compare what you have installed with webguyio Stop Spammers Classic 0 ≤2026.1 0 ≤2026.1. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 0.18%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Jan 28, 2026 · EUVD

    Detected

    The Stop Spammers Classic plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2026.1. This is due to missing nonce validation in the ss_addtoallowlist class. This makes it possible for unauthenticated attackers to add arbitrary email addresses to the spam allowlist via a forged request granted they can trick a site administrator into performing an

  2. Apr 8, 2026 · EUVD

    Updated

    The Stop Spammers Classic plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2026.1. This is due to missing nonce validation in the ss_addtoallowlist class. This makes it possible for unauthenticated attackers to add arbitrary email addresses to the spam allowlist via a forged request granted they can trick a site administrator into performing an

Sources

  • CVE.orgVulnerability recordCVE-2025-14795

    Official CVE identifier

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2025-14795

    30-day exploitation probability 0.18%

    first.org
  • EUVDVulnerability recordEUVD-2025-206511

    The Stop Spammers Classic plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2026.1. This is due to missing nonce validation in the ss_addtoallowlist class. This makes it possible for unauthenticated attackers to add arbitrary e

    euvd.enisa.europa.eu

References

Freshness

Last verified in this catalog Nov 3, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • CVE.orgNov 4, 2026
  • FIRST EPSSNov 3, 2026
  • EUVDNov 2, 2026