Vulnerabilities

Vulnerability · CVE-2025-14865

The Passster – Password Protect Pages and Content plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'content_protector' shortcode in all versions u

Published Jan 28, 2026 · catalog updated Apr 8, 2026 · WPChill Passster – Password Protect Pages and Content

Last checked Nov 4, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2025-14865. EPSS is 0.28%. Act only if a listed version of WPChill Passster – Password Protect Pages and Content is installed.

Gaps on this record

  • No vendor fix or required action is stored. Compare the linked advisory before you change production.
Severity
Medium6.4
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.28%
Remediation
Vendor / distro source
Affected products
vendor WPChill Passster – Password Protect Pages and Content 0 ≤4.2.24

The Passster – Password Protect Pages and Content plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'content_protector' shortcode in all versions up to, and including, 4.2.24. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 4.2.21.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • vendor WPChill Passster – Password Protect Pages and Content 0 ≤4.2.240 ≤4.2.24

How to fix CVE-2025-14865

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2025-14865. EPSS is 0.28%. Act only if a listed version of WPChill Passster – Password Protect Pages and Content is installed.

Which versions are affected?

Compare what you have installed with WPChill Passster – Password Protect Pages and Content 0 ≤4.2.24 0 ≤4.2.24. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 0.28%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Jan 28, 2026 · EUVD

    Detected

    The Passster – Password Protect Pages and Content plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'content_protector' shortcode in all versions up to, and including, 4.2.24. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected pa

  2. Apr 8, 2026 · EUVD

    Updated

    The Passster – Password Protect Pages and Content plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'content_protector' shortcode in all versions up to, and including, 4.2.24. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected pa

Sources

  • CVE.orgVulnerability recordCVE-2025-14865

    Official CVE identifier

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2025-14865

    30-day exploitation probability 0.28%

    first.org
  • EUVDVulnerability recordEUVD-2025-206505

    The Passster – Password Protect Pages and Content plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'content_protector' shortcode in all versions up to, and including, 4.2.24. This makes it possible for authenticated attackers, with Contributor-le

    euvd.enisa.europa.eu

References

Freshness

Last verified in this catalog Nov 3, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • CVE.orgNov 4, 2026
  • FIRST EPSSNov 3, 2026
  • EUVDNov 2, 2026