Vulnerability · CVE-2025-24313
Improper access control for some Device Plugins for Kubernetes software maintained by Intel before version 0.32.0 may allow a privileged user to potentially enable denial of servic
Published Aug 12, 2025 · catalog updated Aug 13, 2025 · Device Plugins for Kubernetes software maintained by Intel
Last checked Oct 24, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-24313. EPSS is 0.14%. Act only if a listed version of Device Plugins for Kubernetes software maintained by Intel is installed.
Gaps on this record
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- Medium6.7
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.14%
- Remediation
- Version ranges on file
- Affected products
- vendor n/a Device Plugins for Kubernetes software maintained by Intel before version 0.32.0
Improper access control for some Device Plugins for Kubernetes software maintained by Intel before version 0.32.0 may allow a privileged user to potentially enable denial of service via local access.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor n/a Device Plugins for Kubernetes software maintained by Intel before version 0.32.0before version 0.32.0
How to fix CVE-2025-24313
Upgrade
CVE-2025-24313 lists a fix boundary at version. Compare the installed build with that boundary before you change production.
Version check
Seen in before version 0.32.0
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-24313. EPSS is 0.14%. Act only if a listed version of Device Plugins for Kubernetes software maintained by Intel is installed.
Which versions are affected?
Compare what you have installed with n/a Device Plugins for Kubernetes software maintained by Intel before version 0.32.0 before version 0.32.0. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.14%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Aug 12, 2025 · EUVD
Detected
Improper access control for some Device Plugins for Kubernetes software maintained by Intel before version 0.32.0 may allow a privileged user to potentially enable denial of service via local access.
Aug 13, 2025 · EUVD
Fix available
n/a Device Plugins for Kubernetes software maintained by Intel before version 0.32.0 fixed in version 0.32.0
Aug 13, 2025 · EUVD
Updated
Improper access control for some Device Plugins for Kubernetes software maintained by Intel before version 0.32.0 may allow a privileged user to potentially enable denial of service via local access.
Sources
- CVE.orgVulnerability recordCVE-2025-24313
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-24313
30-day exploitation probability 0.14%
first.org - EUVDVulnerability recordEUVD-2025-24410
Improper access control for some Device Plugins for Kubernetes software maintained by Intel before version 0.32.0 may allow a privileged user to potentially enable denial of service via local access.
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Oct 24, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSOct 24, 2026
- CVE.orgOct 21, 2026
- EUVDOct 20, 2026