Vulnerability · CVE-2025-26699
Django Vulnerable to Allocation of Resources Without Limits or Throttling
Published Mar 6, 2025 · catalog updated Nov 4, 2026 · Django Vulnerable to Allocation
Last checked Nov 7, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-26699. EPSS is 0.83%. Act only if a listed version of Django Vulnerable to Allocation is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Django Vulnerable to Allocation).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-15920 · Medium
- CVE-2026-15830 · Medium
- CVE-2026-15337 · Medium
- CVE-2026-15307 · High
- CVE-2026-53878 · Medium
- Severity
- High7.5
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.83%
- Remediation
- Version ranges on file
- Affected products
- PyPI django · cpe debian/debian linux · cpe djangoproject/django · pypi Django
An issue was discovered in Django 5.1 before 5.1.7, 5.0 before 5.0.13, and 4.2 before 4.2.20. The django.utils.text.wrap() method and wordwrap template filter are subject to a potential denial-of-service attack when used with very long strings." -date: "2025-04-09" +date: "2026-11-04" pubdate: "2025-03-06" -affected_range: ">=4.2, =5.0, =5.1, =4.2.0, =5.0.0, =5.1.0,<5.1.7" fixed_versions: - "4.2.2
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- PyPI django4.2 → 4.2.20
- PyPI django5.0 → 5.0.13
- PyPI django5.1 → 5.1.7
- cpe debian/debian linux11.0
- cpe djangoproject/django< 4.2.20
- cpe djangoproject/django< 5.0.13
- cpe djangoproject/django< 5.1.7
- pypi Django>=4.2,<4.2.20||>=5.0,<5.0.13||>=5.1,<5.1.7
How to fix CVE-2025-26699
Upgrade
CVE-2025-26699 lists a fix boundary at 4.2.20. Compare the installed build with that boundary before you change production.
Version check
Affected < 4.2.20
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-26699. EPSS is 0.83%. Act only if a listed version of Django Vulnerable to Allocation is installed.
Which versions are affected?
Compare what you have installed with debian/debian linux 11.0; Django >=4.2,<4.2.20||>=5.0,<5.0.13||>=5.1,<5.1.7. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-770: Allocation of Resources Without Limits or Throttling. EPSS 0.83%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Mar 6, 2025 · GitHub Advisory Database
Detected
An issue was discovered in Django 5.1 before 5.1.7, 5.0 before 5.0.13, and 4.2 before 4.2.20. The django.utils.text.wrap() method and wordwrap template filter are subject to a potential denial-of-service attack when used with very long strings.
Nov 4, 2026 · GitHub Advisory Database
Fix available
django fixed in 4.2.20; django fixed in 5.0.13; django fixed in 5.1.7
Nov 4, 2026 · GitHub Advisory Database
Fix available
django fixed in 4.2.20
Nov 4, 2026 · GitHub Advisory Database
Fix available
django fixed in 5.0.13
Nov 4, 2026 · GitHub Advisory Database
Fix available
django fixed in 5.1.7
Nov 4, 2026 · GitHub Advisory Database
Updated
An issue was discovered in Django 5.1 before 5.1.7, 5.0 before 5.0.13, and 4.2 before 4.2.20. The django.utils.text.wrap() method and wordwrap template filter are subject to a potential denial-of-service attack when used with very long strings.
Sources
- CVE.orgVulnerability recordCVE-2025-26699
Official CVE identifier
cve.org - GitHub Advisory DatabasePackage advisoryGHSA-p3fp-8748-vqfq
GitHub Advisory Database record mirrored by OSV.
github.com - GitLab Advisory DatabasePackage advisorypypi/Django/CVE-2025-26699.yml
An issue was discovered in Django 5.1 before 5.1.7, 5.0 before 5.0.13, and 4.2 before 4.2.20. The django.utils.text.wrap() method and wordwrap template filter are subject to a potential denial-of-service attack when used with very long strings." -date: "2025-04-09" +date: "2026-11-04" pubdate: "2025-03-06" -affected_range: ">=4.2, =5.0, =5.1, =4.2.0, =5.0.0, =5.1.0,<5.1.7" fixed_versions: - "4.2.2
gitlab.com - Monitored products — highVendor advisoryCVE-2025-26699
An issue was discovered in Django 5.1 before 5.1.7, 5.0 before 5.0.13, and 4.2 before 4.2.20. The django.utils.text.wrap() method and wordwrap template filter are subject to a potential denial-of-service attack when used with very long strings.
nvd.nist.gov - OpenSSF OSV / OSV ScannerPackage advisoryGHSA-p3fp-8748-vqfq
Django Vulnerable to Allocation of Resources Without Limits or Throttling
osv.dev - PyPA Advisory DatabasePackage advisoryGHSA-p3fp-8748-vqfq
Django Vulnerable to Allocation of Resources Without Limits or Throttling
osv.dev
References
Freshness
Last verified in this catalog Nov 5, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- Monitored products — highNov 7, 2026
- PyPA Advisory DatabaseNov 6, 2026
- CVE.orgNov 5, 2026
- GitLab Advisory DatabaseNov 5, 2026
- GitHub Advisory DatabaseNov 5, 2026
- OpenSSF OSV / OSV ScannerNov 5, 2026