Vulnerability · CVE-2025-29606
py-libp2p before 0.2.3 allows a peer to cause a denial of service (resource consumption) via a large RSA key.
Published Jul 14, 2025 · catalog updated Jul 14, 2025 · py-libp2p before 0.2.3 allows
Last checked Oct 27, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-29606. EPSS is 0.38%. Act only if a listed version of py-libp2p before 0.2.3 allows is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (py-libp2p before 0.2.3 allows).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- Medium4.3
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.38%
- Remediation
- Version ranges on file
- Affected products
- vendor libp2p py-libp2p 0 <0.2.3
py-libp2p before 0.2.3 allows a peer to cause a denial of service (resource consumption) via a large RSA key.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor libp2p py-libp2p 0 <0.2.30 <0.2.3
How to fix CVE-2025-29606
Upgrade
CVE-2025-29606 lists a fix boundary at 0.2.3. Compare the installed build with that boundary before you change production.
Version check
Seen in 0 <0.2.3
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-29606. EPSS is 0.38%. Act only if a listed version of py-libp2p before 0.2.3 allows is installed.
Which versions are affected?
Compare what you have installed with libp2p py-libp2p 0 <0.2.3 0 <0.2.3. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.38%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Jul 14, 2025 · EUVD
Detected
py-libp2p before 0.2.3 allows a peer to cause a denial of service (resource consumption) via a large RSA key.
Jul 14, 2025 · EUVD
Updated
py-libp2p before 0.2.3 allows a peer to cause a denial of service (resource consumption) via a large RSA key.
Sources
- CVE.orgVulnerability recordCVE-2025-29606
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-29606
30-day exploitation probability 0.38%
first.org - EUVDVulnerability recordEUVD-2025-21304
py-libp2p before 0.2.3 allows a peer to cause a denial of service (resource consumption) via a large RSA key.
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Oct 27, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSOct 24, 2026
- CVE.orgOct 21, 2026
- EUVDOct 19, 2026