Vulnerability · CVE-2025-30151
CVE-2025-30151 is listed by Shopware is an open commerce platform..
Published Apr 8, 2025 · catalog updated Jun 17, 2026 · the affected product
Last checked Nov 6, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-30151. EPSS is 0.43%. Act only if a listed version of the affected product is installed.
Gaps on this record
- No plain product name is stored. The page cannot tell you which product to check.
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-23498 · High
- CVE-2025-67648 · High
- CVE-2025-7954 · Medium
- CVE-2025-51541 · Medium
- CVE-2025-32378 · Medium
- Severity
- High7.5
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.43%
- Remediation
- Version ranges on file
- Affected products
- cpe shopware/shopware
CVE-2025-30151 is listed by Shopware is an open commerce platform..
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe shopware/shopware6.7.0.0
- cpe shopware/shopware< 6.5.8.17
- cpe shopware/shopware< 6.6.10.3
How to fix CVE-2025-30151
Upgrade
CVE-2025-30151 lists a fix boundary at 6.5.8.17. Compare the installed build with that boundary before you change production.
Version check
Affected < 6.5.8.17
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-30151. EPSS is 0.43%. Act only if a listed version of the affected product is installed.
Which versions are affected?
Compare what you have installed with 6.7.0.0, < 6.5.8.17, < 6.6.10.3. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-20: Improper Input Validation. EPSS 0.43%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Apr 8, 2025 · Monitored products — high
Detected
CVE-2025-30151 is listed by Shopware is an open commerce platform..
Jun 17, 2026 · Monitored products — high
Updated
CVE-2025-30151 is listed by Shopware is an open commerce platform..
Sources
- CVE.orgVulnerability recordCVE-2025-30151
Official CVE identifier
cve.org - Monitored products — highVendor advisoryCVE-2025-30151
Shopware is an open commerce platform. It's possible to pass long passwords that leads to Denial Of Service via forms in Storefront forms or Store-API. This vulnerability is fixed in 6.6.10.3 or 6.5.8.17. For older versions of 6.4, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.
nvd.nist.gov
References
Freshness
Last verified in this catalog Nov 6, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgNov 6, 2026
- Monitored products — highNov 6, 2026