Vulnerability · CVE-2025-31944
Race condition for some TDX Module before version tdx1.5 within Ring 0: Hypervisor may allow a denial of service.
Published Feb 10, 2026 · catalog updated Feb 10, 2026 · TDX Module
Last checked Nov 6, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-31944. EPSS is 0.09%. Act only if a listed version of TDX Module is installed.
Gaps on this record
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2025-32467 · Medium
- CVE-2025-30513 · High
- CVE-2025-27940 · Medium
- Severity
- Medium5.6
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.09%
- Remediation
- Version ranges on file
- Affected products
- vendor n/a TDX Module before version tdx1.5
Race condition for some TDX Module before version tdx1.5 within Ring 0: Hypervisor may allow a denial of service. Authorized adversary with a privileged user combined with a high complexity attack may enable denial of service. This result may potentially occur via local access when attack requirements are present without special internal knowledge and requires no user interaction. The potential vulnerability may impact the confidentiality (none), integrity (none) and availability (high) of the vulnerable system, resulting in subsequent system confidentiality (none), integrity (none) and availa
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor n/a TDX Module before version tdx1.5before version tdx1.5
How to fix CVE-2025-31944
Upgrade
CVE-2025-31944 lists a fix boundary at version. Compare the installed build with that boundary before you change production.
Version check
Seen in before version tdx1.5
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-31944. EPSS is 0.09%. Act only if a listed version of TDX Module is installed.
Which versions are affected?
Compare what you have installed with n/a TDX Module before version tdx1.5 before version tdx1.5. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.09%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Feb 10, 2026 · EUVD
Detected
Race condition for some TDX Module before version tdx1.5 within Ring 0: Hypervisor may allow a denial of service. Authorized adversary with a privileged user combined with a high complexity attack may enable denial of service. This result may potentially occur via local access when attack requirements are present without special internal knowledge and requires no user interaction. The potential vu
Feb 10, 2026 · EUVD
Fix available
n/a TDX Module before version tdx1.5 fixed in version tdx1.5
Feb 10, 2026 · EUVD
Updated
Race condition for some TDX Module before version tdx1.5 within Ring 0: Hypervisor may allow a denial of service. Authorized adversary with a privileged user combined with a high complexity attack may enable denial of service. This result may potentially occur via local access when attack requirements are present without special internal knowledge and requires no user interaction. The potential vu
Sources
- CVE.orgVulnerability recordCVE-2025-31944
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-31944
30-day exploitation probability 0.09%
first.org - EUVDVulnerability recordEUVD-2025-207267
Race condition for some TDX Module before version tdx1.5 within Ring 0: Hypervisor may allow a denial of service. Authorized adversary with a privileged user combined with a high complexity attack may enable denial of service. This result may potentially occur via local access wh
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Nov 6, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 6, 2026
- CVE.orgNov 4, 2026
- EUVDNov 3, 2026