Vulnerability · CVE-2025-3466
langgenius/dify versions 1.1.0 to 1.1.2 are vulnerable to unsanitized input in the code node, allowing execution of arbitrary code with full root permissions.
Published Jul 7, 2025 · catalog updated Jul 7, 2025 · langgenius/dify versions 1.1.0 to
Last checked Oct 26, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-3466. EPSS is 0.83%. Act only if a listed version of langgenius/dify versions 1.1.0 to is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (langgenius/dify versions 1.1.0 to).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2025-11750 · Medium
- CVE-2025-3467 · High
- Severity
- Critical9.8
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.83%
- Remediation
- Version ranges on file
- Affected products
- vendor langgenius langgenius/dify unspecified <1.1.3
langgenius/dify versions 1.1.0 to 1.1.2 are vulnerable to unsanitized input in the code node, allowing execution of arbitrary code with full root permissions. The vulnerability arises from the ability to override global functions in JavaScript, such as parseInt, before sandbox security restrictions are imposed. This can lead to unauthorized access to secret keys, internal network servers, and lateral movement within dify.ai. The issue is resolved in version 1.1.3.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor langgenius langgenius/dify unspecified <1.1.3unspecified <1.1.3
How to fix CVE-2025-3466
Upgrade
CVE-2025-3466 lists a fix boundary at 1.1.3. Compare the installed build with that boundary before you change production.
Version check
Seen in unspecified <1.1.3
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-3466. EPSS is 0.83%. Act only if a listed version of langgenius/dify versions 1.1.0 to is installed.
Which versions are affected?
Compare what you have installed with langgenius langgenius/dify unspecified <1.1.3 unspecified <1.1.3. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.83%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Jul 7, 2025 · EUVD
Detected
langgenius/dify versions 1.1.0 to 1.1.2 are vulnerable to unsanitized input in the code node, allowing execution of arbitrary code with full root permissions. The vulnerability arises from the ability to override global functions in JavaScript, such as parseInt, before sandbox security restrictions are imposed. This can lead to unauthorized access to secret keys, internal network servers, and late
Jul 7, 2025 · EUVD
Updated
langgenius/dify versions 1.1.0 to 1.1.2 are vulnerable to unsanitized input in the code node, allowing execution of arbitrary code with full root permissions. The vulnerability arises from the ability to override global functions in JavaScript, such as parseInt, before sandbox security restrictions are imposed. This can lead to unauthorized access to secret keys, internal network servers, and late
Sources
- CVE.orgVulnerability recordCVE-2025-3466
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-3466
30-day exploitation probability 0.83%
first.org - EUVDVulnerability recordEUVD-2025-20212
langgenius/dify versions 1.1.0 to 1.1.2 are vulnerable to unsanitized input in the code node, allowing execution of arbitrary code with full root permissions. The vulnerability arises from the ability to override global functions in JavaScript, such as parseInt, before sandbox se
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Oct 26, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSOct 23, 2026
- CVE.orgOct 21, 2026
- EUVDOct 20, 2026