Vulnerability · CVE-2025-3777
Hugging Face Transformers versions up to 4.49.0 are affected by an improper input validation vulnerability in the file.
Published Jul 7, 2025 · catalog updated Jul 7, 2025 · Hugging Face Transformers versions
Last checked Oct 29, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-3777. EPSS is 0.41%. Act only if a listed version of Hugging Face Transformers versions is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Hugging Face Transformers versions).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2025-6921 · Medium
- CVE-2025-6051 · Medium
- CVE-2025-6638 · Medium
- CVE-2025-5197 · Medium
- CVE-2025-3933 · Medium
- Severity
- Low3.5
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.41%
- Remediation
- Version ranges on file
- Affected products
- vendor huggingface huggingface/transformers unspecified <4.52.1
Hugging Face Transformers versions up to 4.49.0 are affected by an improper input validation vulnerability in the file. The vulnerability arises from insecure URL validation using the method, which can be bypassed through URL username injection. This allows attackers to craft URLs that appear to be from YouTube but resolve to malicious domains, potentially leading to phishing attacks, malware distribution, or data exfiltration. The issue is fixed in version 4.52.1.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor huggingface huggingface/transformers unspecified <4.52.1unspecified <4.52.1
How to fix CVE-2025-3777
Upgrade
CVE-2025-3777 lists a fix boundary at 4.52.1. Compare the installed build with that boundary before you change production.
Version check
Seen in unspecified <4.52.1
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-3777. EPSS is 0.41%. Act only if a listed version of Hugging Face Transformers versions is installed.
Which versions are affected?
Compare what you have installed with huggingface huggingface/transformers unspecified <4.52.1 unspecified <4.52.1. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.41%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Jul 7, 2025 · EUVD
Detected
Hugging Face Transformers versions up to 4.49.0 are affected by an improper input validation vulnerability in the file. The vulnerability arises from insecure URL validation using the method, which can be bypassed through URL username injection. This allows attackers to craft URLs that appear to be from YouTube but resolve to malicious domains, potentially leading to phishing attacks, malware dist
Jul 7, 2025 · EUVD
Updated
Hugging Face Transformers versions up to 4.49.0 are affected by an improper input validation vulnerability in the file. The vulnerability arises from insecure URL validation using the method, which can be bypassed through URL username injection. This allows attackers to craft URLs that appear to be from YouTube but resolve to malicious domains, potentially leading to phishing attacks, malware dist
Sources
- CVE.orgVulnerability recordCVE-2025-3777
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-3777
30-day exploitation probability 0.41%
first.org - EUVDVulnerability recordEUVD-2025-20211
Hugging Face Transformers versions up to 4.49.0 are affected by an improper input validation vulnerability in the file. The vulnerability arises from insecure URL validation using the method, which can be bypassed through URL username injection. This allows attackers to craft URL
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Oct 29, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSOct 23, 2026
- CVE.orgOct 21, 2026
- EUVDOct 20, 2026