Security fix · CVE-2025-46337
ADOdb is a PHP database class library that provides abstractions for performing queries and managing databases.
Published May 1, 2025 · catalog updated Nov 4, 2026 · ADOdb is a PHP
Last checked Nov 5, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-46337. EPSS is 0.76%. Act only if a listed version of ADOdb is a PHP is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (ADOdb is a PHP).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- Critical10.0
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.76%
- Remediation
- Advisory link
- Affected products
- Ubuntu:25.10 libphp-adodb · Ubuntu:26.04:LTS libphp-adodb · Ubuntu:Pro:16.04:LTS libphp-adodb · Ubuntu:Pro:18.04:LTS libphp-adodb · Ubuntu:Pro:20.04:LTS libphp-adodb · Ubuntu:Pro:22.04:LTS libphp-adodb
ADOdb is a PHP database class library that provides abstractions for performing queries and managing databases. Prior to version 5.22.9, improper escaping of a query parameter may allow an attacker to execute arbitrary SQL statements when the code using ADOdb connects to a PostgreSQL database and calls pg_insert_id() with user-supplied data. This issue has been patched in version 5.22.9.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- Ubuntu:25.10 libphp-adodb0 → 5.22.9-0.1
- Ubuntu:26.04:LTS libphp-adodb0 → 5.22.9-0.1
- Ubuntu:Pro:16.04:LTS libphp-adodb0 → 5.20.3-1ubuntu1+esm2
- Ubuntu:Pro:18.04:LTS libphp-adodb0 → 5.20.9-1ubuntu0.1~esm2
- Ubuntu:Pro:20.04:LTS libphp-adodb0 → 5.20.16-1ubuntu0.1~esm2
- Ubuntu:Pro:22.04:LTS libphp-adodb0 → 5.20.19-1ubuntu0.1+esm1
- Ubuntu:Pro:24.04:LTS libphp-adodb0 → 5.21.4-1ubuntu0.1~esm1
How to fix CVE-2025-46337
Upgrade
CVE-2025-46337 lists a fix boundary at 5.22.9-0.1. Compare the installed build with that boundary before you change production.
Version check
Fixed in 5.22.9-0.1 · 5 other ranges on the advisory
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-46337. EPSS is 0.76%. Act only if a listed version of ADOdb is a PHP is installed.
Which versions are affected?
Compare what you have installed with 0 → 5.22.9-0.1, 0 → 5.20.3-1ubuntu1+esm2, 0 → 5.20.9-1ubuntu0.1~esm2, 0 → 5.20.16-1ubuntu0.1~esm2, 0 → 5.20.19-1ubuntu0.1+esm1, 0 → 5.21.4-1ubuntu0.1~esm1. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.76%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
May 1, 2025 · OpenSSF OSV / OSV Scanner
Detected
ADOdb is a PHP database class library that provides abstractions for performing queries and managing databases. Prior to version 5.22.9, improper escaping of a query parameter may allow an attacker to execute arbitrary SQL statements when the code using ADOdb connects to a PostgreSQL database and calls pg_insert_id() with user-supplied data. This issue has been patched in version 5.22.9.
Nov 4, 2026 · OpenSSF OSV / OSV Scanner
Fix available
libphp-adodb fixed in 5.20.3-1ubuntu1+esm2; libphp-adodb fixed in 5.20.9-1ubuntu0.1~esm2; libphp-adodb fixed in 5.20.16-1ubuntu0.1~esm2; libphp-adodb fixed in 5.20.19-1ubuntu0.1+esm1
Nov 4, 2026 · OpenSSF OSV / OSV Scanner
Fix available
libphp-adodb fixed in 5.20.3-1ubuntu1+esm2
Nov 4, 2026 · OpenSSF OSV / OSV Scanner
Fix available
libphp-adodb fixed in 5.20.9-1ubuntu0.1~esm2
Nov 4, 2026 · OpenSSF OSV / OSV Scanner
Fix available
libphp-adodb fixed in 5.20.16-1ubuntu0.1~esm2
Nov 4, 2026 · OpenSSF OSV / OSV Scanner
Fix available
libphp-adodb fixed in 5.20.19-1ubuntu0.1+esm1
Nov 4, 2026 · OpenSSF OSV / OSV Scanner
Fix available
libphp-adodb fixed in 5.21.4-1ubuntu0.1~esm1
Nov 4, 2026 · OpenSSF OSV / OSV Scanner
Fix available
libphp-adodb fixed in 5.22.9-0.1
Nov 4, 2026 · OpenSSF OSV / OSV Scanner
Updated
ADOdb is a PHP database class library that provides abstractions for performing queries and managing databases. Prior to version 5.22.9, improper escaping of a query parameter may allow an attacker to execute arbitrary SQL statements when the code using ADOdb connects to a PostgreSQL database and calls pg_insert_id() with user-supplied data. This issue has been patched in version 5.22.9.
Sources
- CVE.orgVulnerability recordCVE-2025-46337
Official CVE identifier
cve.org - OpenSSF OSV / OSV ScannerPackage advisoryUBUNTU-CVE-2025-46337osv.dev
References
Freshness
Last verified in this catalog Nov 5, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgNov 5, 2026
- OpenSSF OSV / OSV ScannerNov 5, 2026