Vulnerabilities

Security fix · CVE-2025-46819

Redis is an open source, in-memory database that persists on disk.

Published Oct 3, 2025 · catalog updated Oct 31, 2025 · Redis Redis

Last checked Oct 31, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2025-46819. EPSS is 1.09%. Act only if a listed version of Redis Redis is installed.

Gaps on this record

  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
Medium6.3
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
1.09%
Remediation
Version ranges on file
Affected products
cpe redis/redis · vendor Redis Redis < 8.2.2

Redis is an open source, in-memory database that persists on disk. Versions 8.2.1 and below allow an authenticated user to use a specially crafted LUA script to read out-of-bound data or crash the server and subsequent denial of service. The problem exists in all versions of Redis with Lua scripting. This issue is fixed in version 8.2.2. To workaround this issue without patching the redis-server executable is to prevent users from executing Lua scripts. This can be done using ACL to block a script by restricting both the EVAL and FUNCTION command families.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • cpe redis/redis< 6.2.20
  • cpe redis/redis< 7.2.11
  • cpe redis/redis< 7.4.6
  • cpe redis/redis< 8.0.4
  • cpe redis/redis< 8.2.2
  • vendor Redis Redis < 8.2.2< 8.2.2

How to fix CVE-2025-46819

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2025-46819. EPSS is 1.09%. Act only if a listed version of Redis Redis is installed.

Which versions are affected?

Compare what you have installed with Redis Redis < 8.2.2 < 8.2.2. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

CWE-125: Out-of-bounds Read; CWE-190: Integer Overflow. EPSS 1.09%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Oct 3, 2025 · EUVD

    Detected

    Redis is an open source, in-memory database that persists on disk. Versions 8.2.1 and below allow an authenticated user to use a specially crafted LUA script to read out-of-bound data or crash the server and subsequent denial of service. The problem exists in all versions of Redis with Lua scripting. This issue is fixed in version 8.2.2. To workaround this issue without patching the redis-server e

  2. Oct 31, 2025 · EUVD

    Updated

    Redis is an open source, in-memory database that persists on disk. Versions 8.2.1 and below allow an authenticated user to use a specially crafted LUA script to read out-of-bound data or crash the server and subsequent denial of service. The problem exists in all versions of Redis with Lua scripting. This issue is fixed in version 8.2.2. To workaround this issue without patching the redis-server e

Sources

  • CVE.orgVulnerability recordCVE-2025-46819

    Official CVE identifier

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2025-46819

    30-day exploitation probability 1.09%

    first.org
  • EUVDVulnerability recordEUVD-2025-33200

    Redis is an open source, in-memory database that persists on disk. Versions 8.2.1 and below allow an authenticated user to use a specially crafted LUA script to read out-of-bound data or crash the server and subsequent denial of service. The problem exists in all versions of Redi

    euvd.enisa.europa.eu
  • Maintainer security tabsVendor advisoryGHSA-4c68-q8q8-3g4f

    ### Impact An authenticated user may use a specially crafted LUA script to read out-of-bound data or crash the server and subsequent denial of service. The problem exists in all versions of Redis with Lua scripting ### Workarounds An additional workaround to mitigate the problem without patching the redis-server executable is to prevent users from executing Lua scripts. This can be done using ACL

    github.com
  • Monitored products — highVendor advisoryCVE-2025-46819

    Redis is an open source, in-memory database that persists on disk. Versions 8.2.1 and below allow an authenticated user to use a specially crafted LUA script to read out-of-bound data or crash the server and subsequent denial of service. The problem exists in all versions of Redis with Lua scripting. This issue is fixed in version 8.2.2. To workaround this issue without patching the redis-server e

    nvd.nist.gov

References

Freshness

Last verified in this catalog Oct 29, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • Maintainer security tabsOct 31, 2026
  • Monitored products — highOct 31, 2026
  • FIRST EPSSOct 29, 2026
  • CVE.orgOct 23, 2026
  • EUVDOct 23, 2026