Vulnerability · CVE-2025-49124
Untrusted Search Path vulnerability in Apache Tomcat installer for Windows.
Published Jun 16, 2025 · catalog updated Jun 17, 2026 · Untrusted Search Path vulnerability
Last checked Nov 6, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-49124. EPSS is 0.36%. Act only if a listed version of Untrusted Search Path vulnerability is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Untrusted Search Path vulnerability).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-73180 · Medium
- CVE-2026-68763 · High
- CVE-2026-68569 · High
- CVE-2026-68525 · Critical
- CVE-2026-66422 · High
- Severity
- High8.4
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.36%
- Remediation
- Version ranges on file
- Affected products
- cpe apache/tomcat
Untrusted Search Path vulnerability in Apache Tomcat installer for Windows. During installation, the Tomcat installer for Windows used icacls.exe without specifying a full path. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.7, from 10.1.0 through 10.1.41, from 9.0.23 through 9.0.105. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100 and 7.0.95 through 7.0.109. Other EOL versions may also be affected. Users are recommended to upgrade to version 11.0.8, 10.1.42 or 9.0.106, which fix the issue.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe apache/tomcat< 10.1.42
- cpe apache/tomcat< 11.0.8
- cpe apache/tomcat< 9.0.106
How to fix CVE-2025-49124
Upgrade
CVE-2025-49124 lists a fix boundary at 10.1.42. Compare the installed build with that boundary before you change production.
Version check
Affected < 10.1.42
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-49124. EPSS is 0.36%. Act only if a listed version of Untrusted Search Path vulnerability is installed.
Which versions are affected?
Compare what you have installed with < 10.1.42, < 11.0.8, < 9.0.106. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-426: Untrusted Search Path. EPSS 0.36%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Jun 16, 2025 · Monitored products — critical
Detected
Untrusted Search Path vulnerability in Apache Tomcat installer for Windows. During installation, the Tomcat installer for Windows used icacls.exe without specifying a full path. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.7, from 10.1.0 through 10.1.41, from 9.0.23 through 9.0.105. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0
Jun 17, 2026 · Monitored products — critical
Updated
Untrusted Search Path vulnerability in Apache Tomcat installer for Windows. During installation, the Tomcat installer for Windows used icacls.exe without specifying a full path. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.7, from 10.1.0 through 10.1.41, from 9.0.23 through 9.0.105. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0
Sources
- CVE.orgVulnerability recordCVE-2025-49124
Official CVE identifier
cve.org - Monitored products — criticalVendor advisoryCVE-2025-49124
Untrusted Search Path vulnerability in Apache Tomcat installer for Windows. During installation, the Tomcat installer for Windows used icacls.exe without specifying a full path. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.7, from 10.1.0 through 10.1.41, from 9.0.23 through 9.0.105. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0
nvd.nist.gov - urlscan.ioThreat intelligenceCVE-2025-49124urlscan.io
References
Freshness
Last verified in this catalog Nov 6, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- urlscan.ioNov 6, 2026
- CVE.orgNov 4, 2026
- Monitored products — criticalNov 3, 2026