Vulnerability · CVE-2025-52101
linjiashop <=0.9 is vulnerable to Incorrect Access Control.
Published Jul 1, 2025 · catalog updated Jul 2, 2025 · linjiashop <=0.9 is vulnerable
Last checked Oct 26, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-52101. EPSS is 0.46%. Act only if a listed version of linjiashop <=0.9 is vulnerable is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (linjiashop <=0.9 is vulnerable).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-107079 · Unknown
- CVE-2026-95168 · High
- CVE-2025-60475 · Unknown
- CVE-2025-60494 · Unknown
- CVE-2025-60496 · Unknown
- Severity
- Critical9.8
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.46%
- Remediation
- Version ranges on file
- Affected products
- stated n/a · vendor n/a n/a n/a
linjiashop <=0.9 is vulnerable to Incorrect Access Control. When using the default-generated JWT authentication, attackers can bypass the authentication and retrieve the encrypted "password" and "salt". The password can then be obtained through brute-force cracking.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- stated n/a<= 0.9
- vendor n/a n/a n/an/a
How to fix CVE-2025-52101
Upgrade
CVE-2025-52101 lists a fix boundary at 0.9. Compare the installed build with that boundary before you change production.
Version check
Affected <= 0.9
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-52101. EPSS is 0.46%. Act only if a listed version of linjiashop <=0.9 is vulnerable is installed.
Which versions are affected?
Compare what you have installed with n/a n/a n/a n/a. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.46%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Jul 1, 2025 · EUVD
Detected
linjiashop <=0.9 is vulnerable to Incorrect Access Control. When using the default-generated JWT authentication, attackers can bypass the authentication and retrieve the encrypted "password" and "salt". The password can then be obtained through brute-force cracking.
Jul 2, 2025 · EUVD
Updated
linjiashop <=0.9 is vulnerable to Incorrect Access Control. When using the default-generated JWT authentication, attackers can bypass the authentication and retrieve the encrypted "password" and "salt". The password can then be obtained through brute-force cracking.
Sources
- CVE.orgVulnerability recordCVE-2025-52101
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-52101
30-day exploitation probability 0.46%
first.org - EUVDVulnerability recordEUVD-2025-19751
linjiashop <=0.9 is vulnerable to Incorrect Access Control. When using the default-generated JWT authentication, attackers can bypass the authentication and retrieve the encrypted "password" and "salt". The password can then be obtained through brute-force cracking.
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Oct 26, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSOct 23, 2026
- CVE.orgOct 21, 2026
- EUVDOct 20, 2026