Vulnerability · CVE-2025-53020
Late Release of Memory after Effective Lifetime vulnerability in Apache HTTP Server.
Published Jul 10, 2025 · catalog updated Jun 17, 2026 · http server
Last checked Nov 4, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-53020. EPSS is 4.96%. Act only if a listed version of http server is installed.
Gaps on this record
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-93546 · High
- CVE-2026-79768 · Medium
- CVE-2026-73637 · High
- CVE-2026-73636 · High
- CVE-2026-63718 · High
- Severity
- High7.5
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 4.96%
- Remediation
- Version ranges on file
- Affected products
- cpe apache/http server
Late Release of Memory after Effective Lifetime vulnerability in Apache HTTP Server. This issue affects Apache HTTP Server: from 2.4.17 up to 2.4.63. Users are recommended to upgrade to version 2.4.64, which fixes the issue.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- cpe apache/http server< 2.4.64
How to fix CVE-2025-53020
Upgrade
CVE-2025-53020 lists a fix boundary at 2.4.64. Compare the installed build with that boundary before you change production.
Version check
Affected < 2.4.64
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-53020. EPSS is 4.96%. Act only if a listed version of http server is installed.
Which versions are affected?
Compare what you have installed with apache/http server < 2.4.64. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
CWE-401: Missing Release of Memory after Effective Lifetime. EPSS 4.96%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Technology hubs
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Jul 10, 2025 · Monitored products — critical
Detected
Late Release of Memory after Effective Lifetime vulnerability in Apache HTTP Server. This issue affects Apache HTTP Server: from 2.4.17 up to 2.4.63. Users are recommended to upgrade to version 2.4.64, which fixes the issue.
Jun 17, 2026 · Monitored products — critical
Updated
Late Release of Memory after Effective Lifetime vulnerability in Apache HTTP Server. This issue affects Apache HTTP Server: from 2.4.17 up to 2.4.63. Users are recommended to upgrade to version 2.4.64, which fixes the issue.
Sources
- CVE.orgVulnerability recordCVE-2025-53020
Official CVE identifier
cve.org - Monitored products — criticalVendor advisoryCVE-2025-53020
Late Release of Memory after Effective Lifetime vulnerability in Apache HTTP Server. This issue affects Apache HTTP Server: from 2.4.17 up to 2.4.63. Users are recommended to upgrade to version 2.4.64, which fixes the issue.
nvd.nist.gov
References
Freshness
Last verified in this catalog Nov 4, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- CVE.orgNov 4, 2026
- Monitored products — criticalNov 4, 2026