Vulnerabilities

Security fix · CVE-2025-54127

HAXcms with nodejs backend allows users to start the server in any HAXsite or HAXcms instance.

Published Jul 21, 2025 · catalog updated Jul 22, 2025 · HAXcms with nodejs backend

Last checked Oct 26, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2025-54127. EPSS is 0.46%. Act only if a listed version of HAXcms with nodejs backend is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (HAXcms with nodejs backend).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
Critical9.3
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.46%
Remediation
Version ranges on file
Affected products
vendor haxtheweb issues < 11.0.7

HAXcms with nodejs backend allows users to start the server in any HAXsite or HAXcms instance. In versions 11.0.6 and below, the NodeJS version of HAXcms uses an insecure default configuration designed for local development. The default configuration does not perform authorization or authentication checks. If a user were to deploy haxcms-nodejs without modifying the default settings, ‘HAXCMS_DISABLE_JWT_CHECKS‘ would be set to ‘true‘ and their deployment would lack session authentication. This is fixed in version 11.0.7.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • vendor haxtheweb issues < 11.0.7< 11.0.7

How to fix CVE-2025-54127

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2025-54127. EPSS is 0.46%. Act only if a listed version of HAXcms with nodejs backend is installed.

Which versions are affected?

Compare what you have installed with haxtheweb issues < 11.0.7 < 11.0.7. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 0.46%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Jul 21, 2025 · EUVD

    Detected

    HAXcms with nodejs backend allows users to start the server in any HAXsite or HAXcms instance. In versions 11.0.6 and below, the NodeJS version of HAXcms uses an insecure default configuration designed for local development. The default configuration does not perform authorization or authentication checks. If a user were to deploy haxcms-nodejs without modifying the default settings, ‘HAXCMS_DISAB

  2. Jul 22, 2025 · EUVD

    Updated

    HAXcms with nodejs backend allows users to start the server in any HAXsite or HAXcms instance. In versions 11.0.6 and below, the NodeJS version of HAXcms uses an insecure default configuration designed for local development. The default configuration does not perform authorization or authentication checks. If a user were to deploy haxcms-nodejs without modifying the default settings, ‘HAXCMS_DISAB

Sources

  • CVE.orgVulnerability recordCVE-2025-54127

    Official CVE identifier

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2025-54127

    30-day exploitation probability 0.46%

    first.org
  • EUVDVulnerability recordEUVD-2025-22261

    HAXcms with nodejs backend allows users to start the server in any HAXsite or HAXcms instance. In versions 11.0.6 and below, the NodeJS version of HAXcms uses an insecure default configuration designed for local development. The default configuration does not perform authorizatio

    euvd.enisa.europa.eu

References

Freshness

Last verified in this catalog Oct 26, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • FIRST EPSSOct 23, 2026
  • CVE.orgOct 21, 2026
  • EUVDOct 21, 2026