Vulnerability · CVE-2025-55213
OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar.
Published Aug 18, 2025 · catalog updated Aug 18, 2025 · OpenFGA is a high-performance
Last checked Oct 26, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-55213. EPSS is 0.32%. Act only if a listed version of OpenFGA is a high-performance is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (OpenFGA is a high-performance).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-40293 · Medium
- CVE-2026-33729 · Medium
- CVE-2025-48371 · Medium
- CVE-2025-46331 · Medium
- Severity
- Medium5.8
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.32%
- Remediation
- Version ranges on file
- Affected products
- vendor openfga openfga 1.9.3, < 1.9.5
OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. OpenFGA v1.9.3 to v1.9.4 ( openfga-0.2.40 <= Helm chart <= openfga-0.2.41, v1.9.3 <= docker <= v.1.9.4) are vulnerable to improper policy enforcement when certain Check and ListObject calls are executed. This vulnerability is fixed in 1.9.5.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor openfga openfga 1.9.3, < 1.9.51.9.3, < 1.9.5
How to fix CVE-2025-55213
Upgrade
CVE-2025-55213 lists a fix boundary at 1.9.5. Compare the installed build with that boundary before you change production.
Version check
Affected < 1.9.5
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-55213. EPSS is 0.32%. Act only if a listed version of OpenFGA is a high-performance is installed.
Which versions are affected?
Compare what you have installed with openfga openfga 1.9.3, < 1.9.5 1.9.3, < 1.9.5. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.32%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Aug 18, 2025 · EUVD
Detected
OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. OpenFGA v1.9.3 to v1.9.4 ( openfga-0.2.40 <= Helm chart <= openfga-0.2.41, v1.9.3 <= docker <= v.1.9.4) are vulnerable to improper policy enforcement when certain Check and ListObject calls are executed. This vulnerability is fixed in 1.9.5.
Aug 18, 2025 · EUVD
Updated
OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. OpenFGA v1.9.3 to v1.9.4 ( openfga-0.2.40 <= Helm chart <= openfga-0.2.41, v1.9.3 <= docker <= v.1.9.4) are vulnerable to improper policy enforcement when certain Check and ListObject calls are executed. This vulnerability is fixed in 1.9.5.
Sources
- CVE.orgVulnerability recordCVE-2025-55213
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-55213
30-day exploitation probability 0.32%
first.org - EUVDVulnerability recordEUVD-2025-25151
OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. OpenFGA v1.9.3 to v1.9.4 ( openfga-0.2.40 <= Helm chart <= openfga-0.2.41, v1.9.3 <= docker <= v.1.9.4) are vulnerable to improper policy enforcement w
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Oct 26, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSOct 23, 2026
- CVE.orgOct 22, 2026
- EUVDOct 22, 2026