Vulnerabilities

Vulnerability · CVE-2025-55283

aiven-db-migrate is an Aiven database migration tool.

Published Aug 18, 2025 · catalog updated Aug 18, 2025 · aiven-db-migrate is an Aiven

Last checked Oct 26, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2025-55283. EPSS is 0.62%. Act only if a listed version of aiven-db-migrate is an Aiven is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (aiven-db-migrate is an Aiven).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
Critical9.1
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.62%
Remediation
Version ranges on file
Affected products
vendor aiven aiven-db-migrate < 1.0.7

aiven-db-migrate is an Aiven database migration tool. Prior to 1.0.7, there is a privilege escalation vulnerability that allows elevation to superuser inside PostgreSQL databases during a migration from an untrusted source server. The vulnerability stems from psql executing commands embedded in a dump from the source server. This vulnerability is fixed in 1.0.7.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • vendor aiven aiven-db-migrate < 1.0.7< 1.0.7

How to fix CVE-2025-55283

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2025-55283. EPSS is 0.62%. Act only if a listed version of aiven-db-migrate is an Aiven is installed.

Which versions are affected?

Compare what you have installed with aiven aiven-db-migrate < 1.0.7 < 1.0.7. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 0.62%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Aug 18, 2025 · EUVD

    Detected

    aiven-db-migrate is an Aiven database migration tool. Prior to 1.0.7, there is a privilege escalation vulnerability that allows elevation to superuser inside PostgreSQL databases during a migration from an untrusted source server. The vulnerability stems from psql executing commands embedded in a dump from the source server. This vulnerability is fixed in 1.0.7.

  2. Aug 18, 2025 · EUVD

    Updated

    aiven-db-migrate is an Aiven database migration tool. Prior to 1.0.7, there is a privilege escalation vulnerability that allows elevation to superuser inside PostgreSQL databases during a migration from an untrusted source server. The vulnerability stems from psql executing commands embedded in a dump from the source server. This vulnerability is fixed in 1.0.7.

Sources

  • CVE.orgVulnerability recordCVE-2025-55283

    Official CVE identifier

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2025-55283

    30-day exploitation probability 0.62%

    first.org
  • EUVDVulnerability recordEUVD-2025-25128

    aiven-db-migrate is an Aiven database migration tool. Prior to 1.0.7, there is a privilege escalation vulnerability that allows elevation to superuser inside PostgreSQL databases during a migration from an untrusted source server. The vulnerability stems from psql executing comma

    euvd.enisa.europa.eu

References

Freshness

Last verified in this catalog Oct 26, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • FIRST EPSSOct 23, 2026
  • CVE.orgOct 22, 2026
  • EUVDOct 22, 2026