Vulnerabilities

Vulnerability · CVE-2025-56225

fluidsynth-2.4.6 and earlier versions is vulnerable to Null pointer dereference in fluid_synth_monopoly.c, that can be triggered when loading an invalid midi file.

Published Jan 9, 2026 · catalog updated Jan 12, 2026 · fluidsynth-2.4.6 and earlier versions

Last checked Nov 6, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2025-56225. EPSS is 0.46%. Act only if a listed version of fluidsynth-2.4.6 and earlier versions is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (fluidsynth-2.4.6 and earlier versions).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
High7.5
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.46%
Remediation
Version ranges on file
Affected products
stated n/a · vendor n/a n/a n/a

fluidsynth-2.4.6 and earlier versions is vulnerable to Null pointer dereference in fluid_synth_monopoly.c, that can be triggered when loading an invalid midi file.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • stated n/a<= 2.4.6
  • vendor n/a n/a n/an/a

How to fix CVE-2025-56225

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2025-56225. EPSS is 0.46%. Act only if a listed version of fluidsynth-2.4.6 and earlier versions is installed.

Which versions are affected?

Compare what you have installed with n/a n/a n/a n/a. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 0.46%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Jan 9, 2026 · EUVD

    Detected

    fluidsynth-2.4.6 and earlier versions is vulnerable to Null pointer dereference in fluid_synth_monopoly.c, that can be triggered when loading an invalid midi file.

  2. Jan 12, 2026 · EUVD

    Updated

    fluidsynth-2.4.6 and earlier versions is vulnerable to Null pointer dereference in fluid_synth_monopoly.c, that can be triggered when loading an invalid midi file.

Sources

  • CVE.orgVulnerability recordCVE-2025-56225

    Official CVE identifier

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2025-56225

    30-day exploitation probability 0.46%

    first.org
  • EUVDVulnerability recordEUVD-2026-1717

    fluidsynth-2.4.6 and earlier versions is vulnerable to Null pointer dereference in fluid_synth_monopoly.c, that can be triggered when loading an invalid midi file.

    euvd.enisa.europa.eu

References

Freshness

Last verified in this catalog Nov 6, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • FIRST EPSSNov 6, 2026
  • CVE.orgOct 31, 2026
  • EUVDOct 30, 2026