Vulnerability · CVE-2025-5662
A deserialization vulnerability exists in the H2O-3 REST API (POST /99/ImportSQLTable) that affects all versions up to 3.46.0.7.
Published Sep 2, 2025 · catalog updated Sep 2, 2025 · A deserialization vulnerability exists
Last checked Oct 26, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-5662. EPSS is 0.69%. Act only if a listed version of A deserialization vulnerability exists is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (A deserialization vulnerability exists).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2025-6544 · Critical
- CVE-2025-6507 · Critical
- CVE-2025-0782 · Critical
- Severity
- Critical9.8
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.69%
- Remediation
- Version ranges on file
- Affected products
- vendor h2oai h2oai/h2o-3 unspecified <3.46.0.8
A deserialization vulnerability exists in the H2O-3 REST API (POST /99/ImportSQLTable) that affects all versions up to 3.46.0.7. This vulnerability allows remote code execution (RCE) due to improper validation of JDBC connection parameters when using a Key-Value format. The vulnerability is present in the MySQL JDBC Driver version 8.0.19 and JDK version 8u112. The issue is resolved in version 3.46.0.8.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor h2oai h2oai/h2o-3 unspecified <3.46.0.8unspecified <3.46.0.8
How to fix CVE-2025-5662
Upgrade
CVE-2025-5662 lists a fix boundary at 3.46.0.8. Compare the installed build with that boundary before you change production.
Version check
Seen in unspecified <3.46.0.8
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-5662. EPSS is 0.69%. Act only if a listed version of A deserialization vulnerability exists is installed.
Which versions are affected?
Compare what you have installed with h2oai h2oai/h2o-3 unspecified <3.46.0.8 unspecified <3.46.0.8. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.69%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Sep 2, 2025 · EUVD
Detected
A deserialization vulnerability exists in the H2O-3 REST API (POST /99/ImportSQLTable) that affects all versions up to 3.46.0.7. This vulnerability allows remote code execution (RCE) due to improper validation of JDBC connection parameters when using a Key-Value format. The vulnerability is present in the MySQL JDBC Driver version 8.0.19 and JDK version 8u112. The issue is resolved in version 3.46
Sep 2, 2025 · EUVD
Updated
A deserialization vulnerability exists in the H2O-3 REST API (POST /99/ImportSQLTable) that affects all versions up to 3.46.0.7. This vulnerability allows remote code execution (RCE) due to improper validation of JDBC connection parameters when using a Key-Value format. The vulnerability is present in the MySQL JDBC Driver version 8.0.19 and JDK version 8u112. The issue is resolved in version 3.46
Sources
- CVE.orgVulnerability recordCVE-2025-5662
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-5662
30-day exploitation probability 0.69%
first.org - EUVDVulnerability recordEUVD-2025-26414
A deserialization vulnerability exists in the H2O-3 REST API (POST /99/ImportSQLTable) that affects all versions up to 3.46.0.7. This vulnerability allows remote code execution (RCE) due to improper validation of JDBC connection parameters when using a Key-Value format. The vulne
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Oct 26, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSOct 23, 2026
- CVE.orgOct 22, 2026
- EUVDOct 22, 2026