Vulnerability · CVE-2025-57811
Craft is a platform for creating digital experiences.
Published Aug 25, 2025 · catalog updated Aug 25, 2025 · CMS
Last checked Oct 25, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-57811. EPSS is 0.94%. Act only if a listed version of CMS is installed.
Gaps on this record
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2025-64112 · High
- CVE-2025-11941 · Medium
- CVE-2025-11136 · Medium
- CVE-2025-11019 · Medium
- CVE-2025-9400 · Medium
- Severity
- Medium6.1
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.94%
- Remediation
- Version ranges on file
- Affected products
- vendor craftcms CMS 5.0.0-RC1, < 5.8.7
Craft is a platform for creating digital experiences. From versions 4.0.0-RC1 to 4.16.5 and 5.0.0-RC1 to 5.8.6, there is a potential remote code execution vulnerability via Twig SSTI (Server-Side Template Injection). This is a follow-up to CVE-2024-52293. This vulnerability has been patched in versions 4.16.6 and 5.8.7.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor craftcms CMS 5.0.0-RC1, < 5.8.75.0.0-RC1, < 5.8.7
How to fix CVE-2025-57811
Upgrade
CVE-2025-57811 lists a fix boundary at 5.8.7. Compare the installed build with that boundary before you change production.
Version check
Affected < 5.8.7
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-57811. EPSS is 0.94%. Act only if a listed version of CMS is installed.
Which versions are affected?
Compare what you have installed with craftcms CMS 5.0.0-RC1, < 5.8.7 5.0.0-RC1, < 5.8.7. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.94%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Aug 25, 2025 · EUVD
Detected
Craft is a platform for creating digital experiences. From versions 4.0.0-RC1 to 4.16.5 and 5.0.0-RC1 to 5.8.6, there is a potential remote code execution vulnerability via Twig SSTI (Server-Side Template Injection). This is a follow-up to CVE-2024-52293. This vulnerability has been patched in versions 4.16.6 and 5.8.7.
Aug 25, 2025 · EUVD
Updated
Craft is a platform for creating digital experiences. From versions 4.0.0-RC1 to 4.16.5 and 5.0.0-RC1 to 5.8.6, there is a potential remote code execution vulnerability via Twig SSTI (Server-Side Template Injection). This is a follow-up to CVE-2024-52293. This vulnerability has been patched in versions 4.16.6 and 5.8.7.
Sources
- CVE.orgVulnerability recordCVE-2025-57811
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-57811
30-day exploitation probability 0.94%
first.org - EUVDVulnerability recordEUVD-2025-25727
Craft is a platform for creating digital experiences. From versions 4.0.0-RC1 to 4.16.5 and 5.0.0-RC1 to 5.8.6, there is a potential remote code execution vulnerability via Twig SSTI (Server-Side Template Injection). This is a follow-up to CVE-2024-52293. This vulnerability has b
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Oct 25, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSOct 25, 2026
- CVE.orgOct 22, 2026
- EUVDOct 22, 2026