Security fix · CVE-2025-58054
Discourse is an open-source community discussion platform.
Published Oct 1, 2025 · catalog updated Oct 1, 2025 · Discourse is an open-source
Last checked Oct 29, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-58054. EPSS is 0.21%. Act only if a listed version of Discourse is an open-source is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Discourse is an open-source).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2026-91157 · High
- CVE-2026-91156 · High
- CVE-2026-91159 · High
- CVE-2026-34154 · Low
- CVE-2026-33514 · Medium
- Severity
- Low3.5
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.21%
- Remediation
- Version ranges on file
- Affected products
- vendor discourse discourse < 3.5.1
Discourse is an open-source community discussion platform. Versions 3.5.0 and below are vulnerable to XSS attacks through parsing and rendering of chat channel titles and chat thread titles via the quote message functionality when using the rich text editor. This issue is fixed in version 3.5.1.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor discourse discourse < 3.5.1< 3.5.1
How to fix CVE-2025-58054
Upgrade
CVE-2025-58054 lists a fix boundary at 3.5.1. Compare the installed build with that boundary before you change production.
Version check
Affected < 3.5.1
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-58054. EPSS is 0.21%. Act only if a listed version of Discourse is an open-source is installed.
Which versions are affected?
Compare what you have installed with discourse discourse < 3.5.1 < 3.5.1. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.21%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Oct 1, 2025 · EUVD
Detected
Discourse is an open-source community discussion platform. Versions 3.5.0 and below are vulnerable to XSS attacks through parsing and rendering of chat channel titles and chat thread titles via the quote message functionality when using the rich text editor. This issue is fixed in version 3.5.1.
Oct 1, 2025 · EUVD
Updated
Discourse is an open-source community discussion platform. Versions 3.5.0 and below are vulnerable to XSS attacks through parsing and rendering of chat channel titles and chat thread titles via the quote message functionality when using the rich text editor. This issue is fixed in version 3.5.1.
Sources
- CVE.orgVulnerability recordCVE-2025-58054
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-58054
30-day exploitation probability 0.21%
first.org - EUVDVulnerability recordEUVD-2025-33227
Discourse is an open-source community discussion platform. Versions 3.5.0 and below are vulnerable to XSS attacks through parsing and rendering of chat channel titles and chat thread titles via the quote message functionality when using the rich text editor. This issue is fixed i
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Oct 29, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSOct 29, 2026
- CVE.orgOct 23, 2026
- EUVDOct 23, 2026