Vulnerabilities

Vulnerability · CVE-2025-58098

Apache HTTP Server 2.4.65 and earlier with Server Side Includes (SSI) enabled and mod_cgid (but not mod_cgi) passes the shell-escaped query string to #exec cmd="..." directives.

Published Dec 5, 2025 · catalog updated Feb 26, 2026 · Apache Software Foundation Apache HTTP Server

Last checked Oct 27, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2025-58098. EPSS is 1.42%. Act only if a listed version of Apache Software Foundation Apache HTTP Server is installed.

Gaps on this record

  • No vendor fix or required action is stored. Compare the linked advisory before you change production.

Same product and reporting

Severity
High8.3
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
1.42%
Remediation
Version ranges on file
Affected products
vendor Apache Software Foundation Apache HTTP Server 0 <2.4.66

Apache HTTP Server 2.4.65 and earlier with Server Side Includes (SSI) enabled and mod_cgid (but not mod_cgi) passes the shell-escaped query string to #exec cmd="..." directives. This issue affects Apache HTTP Server before 2.4.66. Users are recommended to upgrade to version 2.4.66, which fixes the issue.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • vendor Apache Software Foundation Apache HTTP Server 0 <2.4.660 <2.4.66

How to fix CVE-2025-58098

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2025-58098. EPSS is 1.42%. Act only if a listed version of Apache Software Foundation Apache HTTP Server is installed.

Which versions are affected?

Compare what you have installed with Apache Software Foundation Apache HTTP Server 0 <2.4.66 0 <2.4.66. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 1.42%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Code

The project this record applies to. Exploit listings stay in References.

No public source repository is identified for this product.

Timeline

Detection, updates, and resolution for this record.

  1. Dec 5, 2025 · EUVD

    Detected

    Apache HTTP Server 2.4.65 and earlier with Server Side Includes (SSI) enabled and mod_cgid (but not mod_cgi) passes the shell-escaped query string to #exec cmd="..." directives. This issue affects Apache HTTP Server before 2.4.66. Users are recommended to upgrade to version 2.4.66, which fixes the issue.

  2. Feb 26, 2026 · EUVD

    Updated

    Apache HTTP Server 2.4.65 and earlier with Server Side Includes (SSI) enabled and mod_cgid (but not mod_cgi) passes the shell-escaped query string to #exec cmd="..." directives. This issue affects Apache HTTP Server before 2.4.66. Users are recommended to upgrade to version 2.4.66, which fixes the issue.

Sources

  • CVE.orgVulnerability recordCVE-2025-58098

    Official CVE identifier

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2025-58098

    30-day exploitation probability 1.42%

    first.org
  • EUVDVulnerability recordEUVD-2025-201408

    Apache HTTP Server 2.4.65 and earlier with Server Side Includes (SSI) enabled and mod_cgid (but not mod_cgi) passes the shell-escaped query string to #exec cmd="..." directives. This issue affects Apache HTTP Server before 2.4.66. Users are recommended to upgrade to version 2.4.6

    euvd.enisa.europa.eu

References

Freshness

Last verified in this catalog Oct 27, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • CVE.orgOct 27, 2026
  • FIRST EPSSOct 27, 2026
  • EUVDOct 26, 2026