Vulnerability · CVE-2025-58766
Dyad is a local AI app builder.
Published Sep 17, 2025 · catalog updated Sep 17, 2025 · Dyad is a local
Last checked Oct 29, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-58766. EPSS is 0.44%. Act only if a listed version of Dyad is a local is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Dyad is a local).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- Critical9.1
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.44%
- Remediation
- Version ranges on file
- Affected products
- vendor dyad-sh dyad < 0.20.0
Dyad is a local AI app builder. A critical security vulnerability has been discovered that affected Dyad v0.19.0 and earlier versions that allows attackers to execute arbitrary code on users' systems. The vulnerability affects the application's preview window functionality and can bypass Docker container protections. An attacker can craft web content that automatically executes when the preview loads. The malicious content can break out of the application's security boundaries and gain control of the system. This has been fixed in Dyad v0.20.0 and later.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor dyad-sh dyad < 0.20.0< 0.20.0
How to fix CVE-2025-58766
Upgrade
CVE-2025-58766 lists a fix boundary at 0.20.0. Compare the installed build with that boundary before you change production.
Version check
Affected < 0.20.0
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-58766. EPSS is 0.44%. Act only if a listed version of Dyad is a local is installed.
Which versions are affected?
Compare what you have installed with dyad-sh dyad < 0.20.0 < 0.20.0. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.44%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Sep 17, 2025 · EUVD
Detected
Dyad is a local AI app builder. A critical security vulnerability has been discovered that affected Dyad v0.19.0 and earlier versions that allows attackers to execute arbitrary code on users' systems. The vulnerability affects the application's preview window functionality and can bypass Docker container protections. An attacker can craft web content that automatically executes when the preview lo
Sep 17, 2025 · EUVD
Updated
Dyad is a local AI app builder. A critical security vulnerability has been discovered that affected Dyad v0.19.0 and earlier versions that allows attackers to execute arbitrary code on users' systems. The vulnerability affects the application's preview window functionality and can bypass Docker container protections. An attacker can craft web content that automatically executes when the preview lo
Sources
- CVE.orgVulnerability recordCVE-2025-58766
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-58766
30-day exploitation probability 0.44%
first.org - EUVDVulnerability recordEUVD-2025-29747
Dyad is a local AI app builder. A critical security vulnerability has been discovered that affected Dyad v0.19.0 and earlier versions that allows attackers to execute arbitrary code on users' systems. The vulnerability affects the application's preview window functionality and ca
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Oct 29, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSOct 29, 2026
- CVE.orgOct 23, 2026
- EUVDOct 23, 2026