Vulnerabilities

Vulnerability · CVE-2025-58769

auth0-PHP is an SDK for Auth0 Authentication and Management APIs.

Published Oct 1, 2025 · catalog updated Oct 1, 2025 · auth0-PHP is an SDK

Last checked Oct 29, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2025-58769. EPSS is 0.35%. Act only if a listed version of auth0-PHP is an SDK is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (auth0-PHP is an SDK).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.
Severity
Low3.3
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.35%
Remediation
Version ranges on file
Affected products
vendor auth0 laravel-auth0 3.3.0, < 8.17.0

auth0-PHP is an SDK for Auth0 Authentication and Management APIs. In versions 3.3.0 through 8.16.0, the Bulk User Import endpoint in applications built with the SDK does not validate the file-path wrapper or value. Without proper validation, affected applications may accept arbitrary file paths or URLs. The vulnerability affects any application that either directly uses the Auth0-PHP SDK (versions 3.3.0–8.16.0) or indirectly relies on those versions through the Auth0/symfony, Auth0/laravel-auth0, or Auth0/wordpress SDKs. This issue is fixed in version 8.17.0.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • vendor auth0 laravel-auth0 3.3.0, < 8.17.03.3.0, < 8.17.0

How to fix CVE-2025-58769

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2025-58769. EPSS is 0.35%. Act only if a listed version of auth0-PHP is an SDK is installed.

Which versions are affected?

Compare what you have installed with auth0 laravel-auth0 3.3.0, < 8.17.0 3.3.0, < 8.17.0. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 0.35%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Technology hubs

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Oct 1, 2025 · EUVD

    Detected

    auth0-PHP is an SDK for Auth0 Authentication and Management APIs. In versions 3.3.0 through 8.16.0, the Bulk User Import endpoint in applications built with the SDK does not validate the file-path wrapper or value. Without proper validation, affected applications may accept arbitrary file paths or URLs. The vulnerability affects any application that either directly uses the Auth0-PHP SDK (versions

  2. Oct 1, 2025 · EUVD

    Updated

    auth0-PHP is an SDK for Auth0 Authentication and Management APIs. In versions 3.3.0 through 8.16.0, the Bulk User Import endpoint in applications built with the SDK does not validate the file-path wrapper or value. Without proper validation, affected applications may accept arbitrary file paths or URLs. The vulnerability affects any application that either directly uses the Auth0-PHP SDK (versions

Sources

  • CVE.orgVulnerability recordCVE-2025-58769

    Official CVE identifier

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2025-58769

    30-day exploitation probability 0.35%

    first.org
  • EUVDVulnerability recordEUVD-2025-32693

    auth0-PHP is an SDK for Auth0 Authentication and Management APIs. In versions 3.3.0 through 8.16.0, the Bulk User Import endpoint in applications built with the SDK does not validate the file-path wrapper or value. Without proper validation, affected applications may accept arbit

    euvd.enisa.europa.eu

References

Freshness

Last verified in this catalog Oct 29, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • FIRST EPSSOct 29, 2026
  • CVE.orgOct 23, 2026
  • EUVDOct 23, 2026