Vulnerabilities

Security fix · CVE-2025-59036

Infrahub offers a central hub to manage data, templates, and playbooks.

Published Sep 9, 2025 · catalog updated Sep 10, 2025 · Infrahub offers a central

Last checked Nov 4, 2026. A connected source was read within the last 7 days.

Check if you run it

No confirmed exploitation is on record for CVE-2025-59036. EPSS is 0.19%. Act only if a listed version of Infrahub offers a central is installed.

Gaps on this record

  • The stored product name is a package slug. The name on this page is taken from the title (Infrahub offers a central).
  • No vendor fix or required action is stored. Compare the linked advisory before you change production.
Severity
Medium5.5
Known exploitation
Not in CISA/VulnCheck KEV
EPSS
0.19%
Remediation
Version ranges on file
Affected products
vendor opsmill infrahub 1.4.0, < 1.4.5

Infrahub offers a central hub to manage data, templates, and playbooks. Prior to versiond 1.3.9 and 1.4.5, a bug in the authentication logic will cause API tokens that were deleted and/or expired to be considered valid. This means that any API token that is associated with an active user account can authenticate successfully. This issue is fixed in versions 1.3.9 and 1.4.5. As a workaround, users can delete or deactivate the account associated with a deleted API token to prevent that token from authenticating.

Are you affected?

Enter the version you run. The result uses only the ranges stored on this record.

The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.

  • vendor opsmill infrahub 1.4.0, < 1.4.51.4.0, < 1.4.5

How to fix CVE-2025-59036

What to do

Three questions, each answered from this record only. Confirm the vendor advisory before you patch.

Should you patch?

No confirmed exploitation is on record for CVE-2025-59036. EPSS is 0.19%. Act only if a listed version of Infrahub offers a central is installed.

Which versions are affected?

Compare what you have installed with opsmill infrahub 1.4.0, < 1.4.5 1.4.0, < 1.4.5. Compare the installed version with the linked vendor advisory before you change production.

What should an analyst verify?

No weakness class is stored. EPSS 0.19%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.

Code

The project this record applies to. Exploit listings stay in References.

Timeline

Detection, updates, and resolution for this record.

  1. Sep 9, 2025 · EUVD

    Detected

    Infrahub offers a central hub to manage data, templates, and playbooks. Prior to versiond 1.3.9 and 1.4.5, a bug in the authentication logic will cause API tokens that were deleted and/or expired to be considered valid. This means that any API token that is associated with an active user account can authenticate successfully. This issue is fixed in versions 1.3.9 and 1.4.5. As a workaround, users

  2. Sep 10, 2025 · EUVD

    Updated

    Infrahub offers a central hub to manage data, templates, and playbooks. Prior to versiond 1.3.9 and 1.4.5, a bug in the authentication logic will cause API tokens that were deleted and/or expired to be considered valid. This means that any API token that is associated with an active user account can authenticate successfully. This issue is fixed in versions 1.3.9 and 1.4.5. As a workaround, users

Sources

  • CVE.orgVulnerability recordCVE-2025-59036

    Official CVE identifier

    cve.org
  • FIRST EPSSExploitation probabilityCVE-2025-59036

    30-day exploitation probability 0.19%

    first.org
  • EUVDVulnerability recordEUVD-2025-27503

    Infrahub offers a central hub to manage data, templates, and playbooks. Prior to versiond 1.3.9 and 1.4.5, a bug in the authentication logic will cause API tokens that were deleted and/or expired to be considered valid. This means that any API token that is associated with an act

    euvd.enisa.europa.eu

References

Freshness

Last verified in this catalog Nov 4, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.

  • FIRST EPSSOct 23, 2026
  • CVE.orgOct 22, 2026
  • EUVDOct 22, 2026