Vulnerability · CVE-2025-59048
OpenBao's AWS Plugin generates AWS access credentials based on IAM policies.
Published Oct 23, 2025 · catalog updated Oct 23, 2025 · OpenBao's AWS Plugin generates
Last checked Nov 1, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-59048. EPSS is 0.27%. Act only if a listed version of OpenBao's AWS Plugin generates is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (OpenBao's AWS Plugin generates).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- High8.1
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.27%
- Remediation
- Version ranges on file
- Affected products
- vendor openbao openbao-plugins < 0.1.1
OpenBao's AWS Plugin generates AWS access credentials based on IAM policies. Prior to version 0.1.1, the AWS Plugin is vulnerable to cross-account IAM role Impersonation in the AWS auth method. The vulnerability allows an IAM role from an untrusted AWS account to authenticate by impersonating a role with the same name in a trusted account, leading to unauthorized access. This impacts all users of the auth-aws plugin who operate in a multi-account AWS environment where IAM role names may not be unique across accounts. This vulnerability has been patched in version 0.1.1 of the auth-aws plugin.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor openbao openbao-plugins < 0.1.1< 0.1.1
How to fix CVE-2025-59048
Upgrade
CVE-2025-59048 lists a fix boundary at 0.1.1. Compare the installed build with that boundary before you change production.
Version check
Affected < 0.1.1
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-59048. EPSS is 0.27%. Act only if a listed version of OpenBao's AWS Plugin generates is installed.
Which versions are affected?
Compare what you have installed with openbao openbao-plugins < 0.1.1 < 0.1.1. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.27%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Oct 23, 2025 · EUVD
Detected
OpenBao's AWS Plugin generates AWS access credentials based on IAM policies. Prior to version 0.1.1, the AWS Plugin is vulnerable to cross-account IAM role Impersonation in the AWS auth method. The vulnerability allows an IAM role from an untrusted AWS account to authenticate by impersonating a role with the same name in a trusted account, leading to unauthorized access. This impacts all users of
Oct 23, 2025 · EUVD
Updated
OpenBao's AWS Plugin generates AWS access credentials based on IAM policies. Prior to version 0.1.1, the AWS Plugin is vulnerable to cross-account IAM role Impersonation in the AWS auth method. The vulnerability allows an IAM role from an untrusted AWS account to authenticate by impersonating a role with the same name in a trusted account, leading to unauthorized access. This impacts all users of
Sources
- CVE.orgVulnerability recordCVE-2025-59048
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-59048
30-day exploitation probability 0.27%
first.org - EUVDVulnerability recordEUVD-2025-35697
OpenBao's AWS Plugin generates AWS access credentials based on IAM policies. Prior to version 0.1.1, the AWS Plugin is vulnerable to cross-account IAM role Impersonation in the AWS auth method. The vulnerability allows an IAM role from an untrusted AWS account to authenticate by
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Nov 1, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 1, 2026
- CVE.orgOct 26, 2026
- EUVDOct 26, 2026