Vulnerability · CVE-2025-59302
In Apache CloudStack improper control of generation of code ('Code Injection') vulnerability is found in the following APIs which are accessible only to admins.
Published Nov 27, 2025 · catalog updated Feb 26, 2026 · Apache Software Foundation Apache CloudStack
Last checked Nov 6, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-59302. EPSS is 0.49%. Act only if a listed version of Apache Software Foundation Apache CloudStack is installed.
Gaps on this record
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
Same product and reporting
- CVE-2025-59454 · Medium
- CVE-2025-30675 · Medium
- CVE-2025-22829 · Low
- CVE-2025-26521 · High
- CVE-2025-47849 · High
- Severity
- Medium4.7
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.49%
- Remediation
- Version ranges on file
- Affected products
- vendor Apache Software Foundation Apache CloudStack 4.21.0 <4.22.0
In Apache CloudStack improper control of generation of code ('Code Injection') vulnerability is found in the following APIs which are accessible only to admins. * quotaTariffCreate * quotaTariffUpdate * createSecondaryStorageSelector * updateSecondaryStorageSelector * updateHost * updateStorage This issue affects Apache CloudStack: from 4.18.0 before 4.20.2, from 4.21.0 before 4.22.0. Users are recommended to upgrade to versions 4.20.2 or 4.22.0, which contain the fix. The fix introduces a new global configuration flag, js.interpretation.enabled, allowing administrators to control the interpre
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor Apache Software Foundation Apache CloudStack 4.21.0 <4.22.04.21.0 <4.22.0
How to fix CVE-2025-59302
Upgrade
CVE-2025-59302 lists a fix boundary at 4.22.0. Compare the installed build with that boundary before you change production.
Version check
Seen in 4.21.0 <4.22.0
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-59302. EPSS is 0.49%. Act only if a listed version of Apache Software Foundation Apache CloudStack is installed.
Which versions are affected?
Compare what you have installed with Apache Software Foundation Apache CloudStack 4.21.0 <4.22.0 4.21.0 <4.22.0. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.49%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
No public source repository is identified for this product.
Timeline
Detection, updates, and resolution for this record.
Nov 27, 2025 · EUVD
Detected
In Apache CloudStack improper control of generation of code ('Code Injection') vulnerability is found in the following APIs which are accessible only to admins. * quotaTariffCreate * quotaTariffUpdate * createSecondaryStorageSelector * updateSecondaryStorageSelector * updateHost * updateStorage This issue affects Apache CloudStack: from 4.18.0 before 4.20.2, from 4.21.0 before 4.22.0. Users are re
Feb 26, 2026 · EUVD
Updated
In Apache CloudStack improper control of generation of code ('Code Injection') vulnerability is found in the following APIs which are accessible only to admins. * quotaTariffCreate * quotaTariffUpdate * createSecondaryStorageSelector * updateSecondaryStorageSelector * updateHost * updateStorage This issue affects Apache CloudStack: from 4.18.0 before 4.20.2, from 4.21.0 before 4.22.0. Users are re
Sources
- CVE.orgVulnerability recordCVE-2025-59302
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-59302
30-day exploitation probability 0.49%
first.org - EUVDVulnerability recordEUVD-2025-199820
In Apache CloudStack improper control of generation of code ('Code Injection') vulnerability is found in the following APIs which are accessible only to admins. * quotaTariffCreate * quotaTariffUpdate * createSecondaryStorageSelector * updateSecondaryStorageSelector * updateHost
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Nov 6, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSNov 6, 2026
- CVE.orgOct 27, 2026
- EUVDOct 26, 2026