Vulnerability · CVE-2025-59336
Luanox is a module host for Lua packages.
Published Sep 16, 2025 · catalog updated Sep 16, 2025 · Luanox is a module
Last checked Oct 29, 2026. A connected source was read within the last 7 days.
Check if you run it
No confirmed exploitation is on record for CVE-2025-59336. EPSS is 0.45%. Act only if a listed version of Luanox is a module is installed.
Gaps on this record
- The stored product name is a package slug. The name on this page is taken from the title (Luanox is a module).
- No vendor fix or required action is stored. Compare the linked advisory before you change production.
- Severity
- Medium6.9
- Known exploitation
- Not in CISA/VulnCheck KEV
- EPSS
- 0.45%
- Remediation
- Version ranges on file
- Affected products
- vendor lumen-oss luanox < 0.1.1
Luanox is a module host for Lua packages. Prior to 0.1.1, a file traversal vulnerability can cause potential denial of service by overwriting Phoenix runtime files. Package names like ../../package are not properly filtered and pass the validity check of the rockspec verification system. This causes the uploaded file to be stored at the relative path location. If planned carefully, this could overwrite a runtime file and cause the website to crash. This vulnerability is fixed by 0.1.1.
Are you affected?
Enter the version you run. The result uses only the ranges stored on this record.
The check returns affected, not affected, or incomplete. It does not guess a version that is missing from the record.
- vendor lumen-oss luanox < 0.1.1< 0.1.1
How to fix CVE-2025-59336
Upgrade
CVE-2025-59336 lists a fix boundary at 0.1.1. Compare the installed build with that boundary before you change production.
Version check
Affected < 0.1.1
Advisory
Open the cve_org record and follow its fix.
Official advisories
What to do
Three questions, each answered from this record only. Confirm the vendor advisory before you patch.
Should you patch?
No confirmed exploitation is on record for CVE-2025-59336. EPSS is 0.45%. Act only if a listed version of Luanox is a module is installed.
Which versions are affected?
Compare what you have installed with lumen-oss luanox < 0.1.1 < 0.1.1. Compare the installed version with the linked vendor advisory before you change production.
What should an analyst verify?
No weakness class is stored. EPSS 0.45%. There is no CISA KEV listing. No Exploit-DB or Metasploit reference is linked. Use the source links for the original advisory.
Code
The project this record applies to. Exploit listings stay in References.
Timeline
Detection, updates, and resolution for this record.
Sep 16, 2025 · EUVD
Detected
Luanox is a module host for Lua packages. Prior to 0.1.1, a file traversal vulnerability can cause potential denial of service by overwriting Phoenix runtime files. Package names like ../../package are not properly filtered and pass the validity check of the rockspec verification system. This causes the uploaded file to be stored at the relative path location. If planned carefully, this could over
Sep 16, 2025 · EUVD
Updated
Luanox is a module host for Lua packages. Prior to 0.1.1, a file traversal vulnerability can cause potential denial of service by overwriting Phoenix runtime files. Package names like ../../package are not properly filtered and pass the validity check of the rockspec verification system. This causes the uploaded file to be stored at the relative path location. If planned carefully, this could over
Sources
- CVE.orgVulnerability recordCVE-2025-59336
Official CVE identifier
cve.org - FIRST EPSSExploitation probabilityCVE-2025-59336
30-day exploitation probability 0.45%
first.org - EUVDVulnerability recordEUVD-2025-29636
Luanox is a module host for Lua packages. Prior to 0.1.1, a file traversal vulnerability can cause potential denial of service by overwriting Phoenix runtime files. Package names like ../../package are not properly filtered and pass the validity check of the rockspec verification
euvd.enisa.europa.eu
References
Freshness
Last verified in this catalog Oct 29, 2026. Significant claims (KEV, EPSS, CVSS, affected ranges) come from the source rows above — open the original publisher for the authoritative advisory.
- FIRST EPSSOct 29, 2026
- CVE.orgOct 23, 2026
- EUVDOct 23, 2026